The Planted Tank Forum - Reply to Topic
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > General Planted Tank Forums > Tank Journals > CRS Spec Journal

Thread: CRS Spec Journal Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-07-2013 09:15 AM
MABJ
Quote:
Originally Posted by That70sfishboy View Post
Gah, that sucks. I loved this tank soo much haha. And I'm glad to see you're posting again
You and me both! I have what is in my opinion a much prettier tank right now (most recent pic of my almost-ADA build). I love that tank a lot, and I think I'll be able to keep it in its prime.

Glad to see familiar faces!
12-07-2013 03:29 AM
That70sfishboy Gah, that sucks. I loved this tank soo much haha. And I'm glad to see you're posting again
12-07-2013 12:02 AM
MABJ Dead basically.

Sad, but it's time. Ah well. I truly did see this tank in its prime, but in the future I need to learn to keep them in their prime.

Down to 1 CRS.

Great to hear from you, man!
12-06-2013 10:52 PM
That70sfishboy Update on this bad boy?
09-02-2013 01:51 AM
MABJ It needed some major plant culling lol. So I got rid of some floaters and moss.

I've got a little algae, but the shrimp seem to like picking at it.

I currently have no way to upload a picture. I'll diagnose the issue and try to fix it.

Is anybody else with an iPhone having trouble with "This is not a valid image file"?
08-29-2013 11:15 PM
MABJ Sure! Later tonight.
08-29-2013 06:57 PM
Jdiesels Update?


DBP Member 003
07-17-2013 09:10 PM
That70sfishboy I think we all love our shrimp!
07-17-2013 08:05 PM
MABJ Feedings!!!! Lol sorry. Although I give them lots of love :p
07-17-2013 07:12 PM
That70sfishboy feelings?
07-17-2013 05:55 PM
MABJ Maybe.. Who knows. What's important is keeping ze babies alive. Do they need lots of extra food and feelings?
07-17-2013 05:19 PM
hambone870 Of the handful of shrimps I've lost, ive not found a single body yet

either they crawl off or maybe they get eaten just that fast?
07-17-2013 05:11 PM
MABJ
Quote:
Originally Posted by That70sfishboy View Post
Did you check the back part of the spec? (Forgetting what it's called)
I've got that closed off.. Hmn
07-17-2013 04:45 PM
That70sfishboy Did you check the back part of the spec? (Forgetting what it's called)
07-17-2013 01:14 PM
MABJ
Quote:
Originally Posted by That70sfishboy View Post
Whaaaaaaaaaaaaaaat! Where'd they gooo??!
Not a clue /:
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 04:12 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012