The Planted Tank Forum - Reply to Topic
Thread: Newbie from VA Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
02-08-2013 12:43 PM
chale Thanks for the welcomes. I'm sure this site will make my tank a success and everyone's info will be used to the fullest. LOL
02-06-2013 12:12 AM
cichnatic Welcome to TPT!
02-05-2013 11:54 PM
wendyjo Another NoVa person! Welcome!
02-05-2013 09:20 PM
Green_Flash Hello, and enjoy the forum!
02-05-2013 08:07 PM
urbguy Welcome to the forum! I am sure you'll be able to find most, if not all, of your questions answered here!
02-05-2013 02:17 PM
GMYukonon24s Welcome to the forum.
02-05-2013 11:01 AM
Newbie from VA

Hey all. Name is Chris and I live in Culpeper, VA. I currently have a 56 gallon fish only and a 10 gallon I'm gathering things for to start a low tech set up. If I can get the 10 gallon running properly, I'm going to plant the 56 gallon too. I have a community tank with angels, danios and cardinal tetras. I had a planted tank before, but it was a horrible experience. That was years ago and now I've tried to take the time to study and read before trying again. Much more patient now and days.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome