The Planted Tank Forum - Reply to Topic
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > General Planted Tank Forums > General Planted Tank Discussion > Plants are curling up. Need Advice!

Thread: Plants are curling up. Need Advice! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-04-2013 04:04 PM
HD Blazingwolf most changes take 2 weeks to really show up on most plants, there are some minor things you can notice, but new growth will take time to adjust to changes
02-04-2013 02:52 PM
rteaff Well i have adjusted a few things and tried to get more CO2 in the water. All my plants are thriving and growing like crazy except the one. Im just prepared for that one to fail.

On another note, I did use Ultralife BGA remover. It did clear up the BGA and had no impact on anything else. I was dilligent to remove any waste and as much as i could. Overall, the tank is doing better than ever and my HC is spreading quickly now that it has no film to compete with.
01-29-2013 06:00 AM
fusiongt That specific plant I've had a hard time as well while all my others thrived in high light direct co2 setup. Not sure why either
01-29-2013 05:06 AM
rteaff all good advice, ill try a combination. I guess the good thing is I haven't added fish so i don't have to worry about that element.
01-26-2013 08:09 PM
Hardstuff All good advice. What I would add is to stay away from that 10000k bulb & run 6500-6700k only. BGA will thrive on most spectrums except 6500-6700k spectrums.
I had a big problem with BGA & changing bulbs to 6500k helped a lot. I next added carbon to my canister filter & let all my canisters blast without a spray bar. The carbon is good at controlling DOC's which the BGA will feed off. The carbon is only used during the BGA battle . After it is gone take it out , but You may have to change it out a couple times until the algae is gone. When your tank cycles fully you can try the 1 day blackout with antibiotic if it is not gone. In my case all the elements mentioned were needed to kill it off since it was very viral in my case. It lasted for months until I changed my bulbs, added carbon, blackout with flagil antibiotic & added flow. The nitrates need to stay above 10ppms or you will never get rid of it. That being said you must keep all the nutrients up as well as CO2. Pressurized CO2 will be best at least 16-38 mg/L of it. Nitrates can never crash or it could come back.
My tank has been BGA free now for 3 months & the water is crystal clear without any sign of algae on my plants or even glass.
I would cut your tank with r/o water to get those incoming nitrates down to near zero. You did not mention what your Kh was or Gh. If your Kh is high it will be difficult to get enough CO2 into the water. High Gh could be a problem as well. Make sure to add Gh booster if the opposite.
My 2 cents
01-26-2013 07:38 PM
HD Blazingwolf since the tank is so new, remove manually as much as possible, fluff everything around with the filter off, perform a 80% water change
perform a 1 day blackout and come back with aother 80% water change


this should remove a TON of bga for u and hopefully help u stabilize things
01-26-2013 07:27 PM
rteaff That was my main concern; afraid to ruin any good bacteria since it was so new. On the other hand i am struggling at keeping the bga in control since it is spreading. Also picking it off of my HC is not easy. I have read that the ulralife targets the right type of bacteria mostly.
01-26-2013 07:08 PM
HD Blazingwolf the bga is likely contributed to ur bacterial colony growing.
keeping the bga low while letting ur bacterium grow in will help
01-26-2013 07:03 PM
rteaff Ill try to up my C02. i'm currently at about 4bps but im beginning to question the reactor as i am never in the green on my indicator. I also have been supplementing quite a bit of Excel.

As for the BGA i am about to try ultra life BGA remover before i try the other antibiotic.

So their doesn't seem to be a problem with my fert program? I plan on slowing down the water changes to 50% every week but since it was a new set up i was doing it very frequently and its taking its tole on me.
01-26-2013 02:10 PM
HD Blazingwolf classic co2 deficiency right there
40ppm nitrates wont hurt a thing either.. adding more co2 will help utilite more of the nitrates though
01-26-2013 05:31 AM
danakin As for the BGA, erythromycin helps.
01-26-2013 05:30 AM
danakin I've got the same thing going on. Boosting CO2 and GH booster will help clear this up.
01-26-2013 04:38 AM
rteaff I am not using RO in the tank but only in the fert mix, so not adding anything additional to that. Currently only testing Nitrite, Nitrate and PH

PH is >7.6, NO2~ .25ppm and NO3 ~40ppm

My tap water has nitrates in it so its something i cant help much, Im using Prime as the conditioner.
01-26-2013 02:59 AM
Dx3Bash What is your Gh and Kh? Also, are you adding anything other than Plant ferts to your RO, such as GLA Gh Booster or Seachem Equilibrium?
01-26-2013 02:34 AM
rteaff
Plants are curling up. Need Advice!

Hey everyone, I am new and usually research forums rather than posting but i figured some specific help might be of benefit.

I had a planted tank years ago and decided to start again.
Current set up:
40g, Current USA fixture with sunpaq bulbs (6700k/10k), Fluval 205 and 306, CO2 injected with red sea reactor (though I'm starting to wonder if its working).

Ferts-
My macro nutrient mix is;
10 teaspoons of Potassium Nitrate
2 and a half teaspoons of Potassium Phosphate
dissolved in 500ml RO/deionised or distilled water

My micro nutrient is; 3 teaspoons of CSM+B
5 teaspoons of Potassium Sulphate
dissolved in 500ml RO/deionised or distilled water

dosed at 7ml and 15 ml a day.

The tank is 3 weeks old and filters started from scratch.

I have been battling hair algae and won with the help of Excel but now i am about to be over run with BGA.

I have done 40%> water changes every other day....FOR 3 WEEKS!

All this to say what is going on with my plant

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 10:29 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012