The Planted Tank Forum - Reply to Topic
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > General Planted Tank Forums > General Planted Tank Discussion > 10 gallon grow all...

Thread: 10 gallon grow all... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-25-2013 12:51 AM
zoragen
Quote:
Originally Posted by NWA-Planted View Post
Now... If it worked on my wife haha
And my BF
01-24-2013 09:41 PM
NWA-Planted
Re: 10 gallon grow all...

Quote:
Originally Posted by zoragen View Post
Very nice!

Benign neglect seems to work
Now... If it worked on my wife haha

Sent from my SCH-I535 using Tapatalk 2
01-23-2013 12:38 AM
zoragen Very nice!

Benign neglect seems to work
01-22-2013 04:27 PM
NWA-Planted
Quote:
Originally Posted by GMYukonon24s View Post
Beautiful Lotus!
Actually labled that wrong should be a red, just looks purple

Sent from my SCH-I535 using Tapatalk 2
01-22-2013 04:19 PM
GMYukonon24s Beautiful Lotus!
01-22-2013 04:16 PM
NWA-Planted
Quote:
Originally Posted by Jim_PA View Post
You are so lucky.
Hardly my 125 always had bba!!!

Sent from my SCH-I535 using Tapatalk 2
01-22-2013 03:37 PM
Jim_PA You are so lucky.
01-22-2013 02:41 PM
NWA-Planted It's a little freak of nature for sure, hopefully i can duplicate this success on my next big tank!! Lol

Sent from my SCH-I535 using Tapatalk 2
01-22-2013 02:36 PM
Silmarwen I wish my tanks would do that for me, haha. I love the wild look of it, though! And if there's no algae choking it out, all the better
01-22-2013 02:28 PM
NWA-Planted
10 gallon grow all...

Just wanted to share some photos of my neglected 10 gallon. Literally just throw plants in no ferts etc, everything grows in this tank and no algae.. Who knows!!



Crypts


Ludwigia


Purple Lotus


This tank is just my little enigma lol

Sent from my SCH-I535 using Tapatalk 2

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 04:37 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012