The Planted Tank Forum - Reply to Topic
Thread: Root "Balls" above the substrate. Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
01-22-2013 12:57 AM
jester56 Thanks, Guys. I did cut them yesterday and they look ok today. Now if I can figure out why certain plants get stem rot and others don't.
01-20-2013 01:26 PM
csf plant will be fine if you cut them.
01-20-2013 12:19 PM
OVT Just cut them off at the stem.
01-20-2013 06:58 AM
jester56 It may well have. I've had a few of my thick stemmed plants have roots grow from the joints. When the roots get a hold, the stems rot. This one has roots so thick that you can hardly see the stem. Crazy. Thanks!
01-20-2013 06:26 AM
Jeffww Won't hurt the plant. Go for it. Although honestly I'd check to make sure the lower portion of the stem hasn't died.
01-20-2013 06:22 AM
jester56 Hello? With a photo, somebody on the board should have an opinion on the "root" of this question. I'd sincerely appreciate any help. Thx!
01-19-2013 01:50 PM
Root "Balls" above the substrate.

I have some Limnophila aromatica in my 50 that are quite healthy. Only problem is that they have developed large root outcroppings from the lower stalks. Not one or two little sprigs, but a snarl of thick roots. Remedy would be just to cut them off. However, I'd like to see if anyone else has had the same problem and what they did about it, if anything. Will it kill the plants to cut them off?


Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome