The Planted Tank Forum - Reply to Topic
Thread: Fluval Chi dry start build Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
01-12-2013 03:41 AM
amajoh This looks great!
01-11-2013 10:20 PM
Originally Posted by skywhitney View Post
I might have some if you're interested. :-)
I shall hit you up sir, oh yes i shall.

And an update
01-10-2013 03:41 AM
skywhitney I might have some if you're interested. :-)
01-09-2013 09:35 PM
dreamchick i will have to try that some time.
01-09-2013 09:35 PM
dreamchick that's cool! good job.
01-09-2013 08:01 PM
jetajockey thanks, going to go find some Hemianthus glomeratus for the next tank.
01-09-2013 06:38 AM
skywhitney pretty sick man!
01-09-2013 01:18 AM
GMYukonon24s Nice tank and growth! Also good job with the slideshow.
01-07-2013 05:23 AM
Fluval Chi dry start build

I didn't know where to post this so I just figured it could go here. I did a fluval chi dry start with some stuff I had laying around, spent about 7 or so weeks letting it grow in and filled it. Here's a slideshow, hope you enjoy.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome