The Planted Tank Forum - Reply to Topic
Thread: Needle Valve - Swagelok S Series not cutting it! Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
12-31-2012 04:05 AM
oldpunk78 ^ basically, all you have to do is loosen the Allen on the end and slide the handle out until you hit your lowest desired rate. Move it too much and tighten it down too hard and you'll break it. Go in small increments.

If set correctly, you'll have about one turn to from zero to about one and a half bubbles per second.
12-31-2012 01:28 AM
DeadlyMuffin
Quote:
Originally Posted by Darkblade48 View Post
I could still adjust it with a delivery pressure of 5 PSI.
That's probably the difference. I can't get much lower than 10psi with the regulator I'm using.

Quote:
Originally Posted by oldpunk78 View Post
Those things come from the factory so that when closed, it's not really closed. You'll need to take the handle off and reset the zero point to what ever you want. Know that it's easy to break the needle off if you close the valve completely.
You're right, they're not designed to completely close. I didn't know they could be modified though! I didn't see how to do it from the diagram on the Swagelok site, how do you get it apart?

edit: Do I loosen the top set screw, unscrew the handle slightly, then retighten the set screw? That would put the handle slightly higher up on the stem.
12-31-2012 01:21 AM
Darkblade48
Quote:
Originally Posted by DeadlyMuffin View Post
What was your pressure behind your valve? If my regulator went lower than 10psi I'd be able to drop the flow rate that way.
I could still adjust it with a delivery pressure of 5 PSI.
12-30-2012 08:42 PM
oldpunk78 Those things come from the factory so that when closed, it's not really closed. You'll need to take the handle off and reset the zero point to what ever you want. Know that it's easy to break the needle off if you close the valve completely.
12-30-2012 08:39 PM
Bandit1200 In my experience the lower the psi, the harder it is to get a consistent flow rate out of the system. I usually run mine in the 15-20 range.
12-30-2012 07:28 AM
DeadlyMuffin I put it in front of the solenoid because it was convenient with the parts I had. I don't think it it makes a difference.

I read the Swagelok writeup on these valves, they have a stop to keep them from being closed too far and getting damaged so I'm skeptical that I damaged it that way. It was bought off ebay though, so who knows what the previous owner did to it.

What was your pressure behind your valve? If my regulator went lower than 10psi I'd be able to drop the flow rate that way.
12-30-2012 07:23 AM
Darkblade48 Just curious as to why you have the needle valve before the solenoid...most people have it the other way around.

Also, I used the exact same metering valve and was able to get it down to 1 bubble per 3-4 seconds.

I do not believe that particular metering valve was designed to be closed completely either, so if you did, it may have damaged it.
12-30-2012 06:48 AM
DeadlyMuffin
Needle Valve - Swagelok S Series not cutting it!

I put together a DIY CO2 regulator setup that I'm having trouble with. I'm using a Victor regulator, and a Swagelok S series (SS-SS2-A to be exact) valve to meter the CO2 flow.

With the regulator set at 10psi, which is as low as I can get it, I'm getting more bubbles than I want even with the valve completely closed.

Has anyone else used S series valves in this kind of setup? Does it sound like I've got a defective part, or the wrong part for the job?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome