The Planted Tank Forum - Reply to Topic
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Fertilizers and Water Parameters > Rising nitrates even after water changes!

Thread: Rising nitrates even after water changes! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-26-2012 06:47 PM
Hardstuff I also even just double checked my API Nitrate test kit comparing it to r/o water. It registered zero. So it appears to be working & I trust it because of the way the tank was & is doing. I used it to prevent Nitrates from crashing below 5ppm & always worked for me. I dosed KNO3 to 10-20ppm & left it that way until reset. Then it would always show 5ppms or less after water change. But back then I had more algae to as well. Now with NO algae my nitrates are high! Say 20-35ppm at times with normal Nitrate dosing. So I decided last week to stop dosing KNO3 & to my surprise the levels still stay above 20ppms!
12-26-2012 06:33 PM
Hardstuff I forgot to mention the filters. Since I have 2 , I stagger the cleanings. I clean the main one every 4-5 weeks & the smaller one every 4 weeks. 100% cleaning not partial. Always using fresh water without chlorine & tank water. I even replaced some of the sponges & replace all the wool. I am still using original media & most sponges still. The main was not even that dirty when I cleaned it last.
The tank besides the snails has a very low bio load.
12-26-2012 06:22 PM
Hardstuff my CO2 is pumping well. I use a diffuser & I check it all the time, plus I measure Kh with ph to check levels. I average 20-25 mg/l. The plants are growing well & the ph gets pushed down to 6.7 6.8 by late evening. Not the cause because I had good plant growth & lower nitrates under the same conditions. The purigen sounds worth a try but is not really fixing the root cause. Although in shrimp tanks with slow growing plants I would give that a try.
I feel the problem is with the substrate. The tank had a rough early stage with not sufficient filtration. I added a second canister to lower doc's. I feel the nitrates have built up in the substrate & I need to concentrate on that more. The other idea I have is with snails. The population exploded on me. I have culled many, but need to take the whole population out to see what happens. I have been reading about snails & the relationship between internal flukes with fish. Has anybody else read the same? Anyway I was wondering if all those snails could be contributing to high nitrates?? Thanks
12-26-2012 02:52 PM
jack25 I used Seachem Purigen to knock down the nitrate in my tank with good success. I also jsut got some amazonian frogbits that are supposed to suck up nitrate.
12-26-2012 12:05 PM
steven p Clean your filters more? Is your co2 still pumping?
12-26-2012 06:12 AM
Hardstuff
Rising nitrates even after water changes!

I have a 10 gallon heavily planted tank. Semi full carpet + 65% bio mass in stem plants overall in the water column. High tech pressurized CO2 with dry ferts. 30 watts T8 (2x15) 6500k bulbs. Gh 6 , Kh 4 , (Ph 7.3- 6.7). Twin canister filters. Flourite substrate. The tank currently has zero algae visible. The system is now maturing into its 5th month. The plants are growing well with good natural colors. The tank only has 2 cherry shrimps & a small snail population that was getting out of hand so I culled about 80% of them because they were eating some of the plants. I am almost ready to do a re stock of 5 small Amber tetras waiting in quarantine now. The question is: My Nitrates were as low as 5 ppm after water changes in the past , say 30 days ago. Now after doing regular weekly water changes I can not get my Nitrates down below 20ppm's even when I know my new water going in is less than 2ppm's??? I feed the shrimps ( Repashy Shrimp Souffle ) a small chunk every other day & thats it. Could the growing snail population be causing the Nitrate rise?? or the food. I have been having trouble vacuuming the subsrtate because of the plant density & carpet. I stopped dosing KNO3, for the last week even though I follow the rules for dry ferts. Nitrate stays above 20ppm's know matter what I do. I use to dose 2 or 3 drops per day & the tank would eat it right up now even though the tank looks great the Nitrates are staying high. Any ideas???? Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 03:20 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012