The Planted Tank Forum - Reply to Topic
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Equipment > milwaukee co2 regulator (ma957) issue

Thread: milwaukee co2 regulator (ma957) issue Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
12-13-2012 04:37 AM
Darkblade48 Unfortunately, this seems to be one of the more common problems with Milwaukee regulators. I assume that your CO2 cylinder is still full of gas (or has been (re)filled recently).

The needle valve tends to be very floaty, and when you think it is set, you will come back a few hours later to find that the bubble rate has drastically changed (as you have already found out).

The problem that you are experiencing has nothing to do with the solenoid (I assume that if you unplug the solenoid, gas no longer flows), but rather the needle valve.

You can try replacing the needle valve, or if you are looking for a completely new setup, you can try DIY-ing your own pressurized CO2 setup.
12-13-2012 04:25 AM
Varma
milwaukee co2 regulator (ma957) issue

Hi All,

I am having strange issue with my milwaukee co2 ma957 regulator.


I purchased this regulator New 1 year back. But I havent used this much.

Last Year when I used, I configured my bubble count to 10 bubbles per min on my Heavy planted tank with Eco Complete and Mineralized Soil Substrate. The Plants were Thrived. but Unfortunately after 2 weeks of contineous use with automatic timer, one day some how it released tun of bubbles/sec which caused CO2 issues in my tank and I lost 3 discus fish on that day. I thought accidently the volve might got turned when i did the water changes.

After that I havent used this device on my discus tank . My plants were doing OK till last month but not great. This month I started using this again and Today I ran into the same issue where it automatically released ton of bubbles without any interval for some time. I got lucked out this time because my wife figured the CO2 bubble count difference this time. After 3 hours of contineous Air Bubbles CO2 evoporation all my fish recovered. This time I am sure this is regulator issue. As of yesterday it was releasing 10 bubbles for min today the same setup released ton of bubbles(contineous flow). No one touched the aquarium cabinet from last water change (5 days ago)

I was wondering whether someone faced the same issue with this ma957 model( Milwaukee CO2 regulator with selenoid ) or any other CO2 regulator.

If so how to resolve this issue. If this is an issue with regulator, does Milwakee Instruments replace this selenoid.

Please share your experience.
Thanks in advance.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 02:38 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012