The Planted Tank Forum - Reply to Topic
Thread: Looking for glosso Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
12-10-2012 03:46 PM
Originally Posted by aokashi View Post
o____O head ouch
shush, I fixed my early morning rambling.
12-10-2012 03:44 PM
Originally Posted by cprash View Post
Make sure you don't get any glosso they attached to rocks though, they left those in the rockwool before sticking it on the rock.
o____O head ouch
12-10-2012 01:49 PM
cprash Make sure you don't get any glosso that Pacific attached to rocks though. Those pieces are still rooted in the rockwool before attaching it to the rock.
12-10-2012 01:43 PM
Originally Posted by aokashi View Post
they do
12-10-2012 09:44 AM
aokashi they do
12-10-2012 05:11 AM
Originally Posted by eeng168 View Post
Anyone have glosso to sell locally?

I need enough to start up a 10 gallon foreground.

I'll just try to find time to go down to pacific and hope they have it
12-10-2012 02:35 AM
acitydweller i may have 3-4 stands left in my planter that you can have.
12-10-2012 02:34 AM
aokashi how much you need?
12-10-2012 01:35 AM
Looking for glosso

Anyone have glosso to sell locally?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome