The Planted Tank Forum - Reply to Topic
Thread: Aquavitro Mineralize and shrimp tank Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
11-11-2012 09:59 PM
arsNatura Ok, that is what I figured, slowly adding non mineralized distilled to balance it out. It was only over the course of a day, though so I am worried I am going to be doing this everyday...i will keep track for a week and see how it goes with this product.
11-11-2012 09:05 PM
GeToChKn As water evaps, the minerals stay and you're going to get some creep unless you top off with distilled without anything in it.
11-11-2012 08:43 PM
Aquavitro Mineralize and shrimp tank

So I decided to make the switch to distilled water (much easier for me to find than ro). And at the time the only mineralizer I could find was aquavitro. I think they only use calcium and magnesium. My shrimp dont seem to be quite happy although it keeps my ph down and hardness where I want I noticed today the params are creeping up by one point or two (api test kits).

I am going to try another mineralizer if I can get it but am starting to wonder if all this work to keep params static is worth it. My tap is a little higher on gh,kh,ph than when I first tested my distilled with mineralize, but I have raised 2 baby crs and only lost one in my tap in a 4gw.

So I dont know if I am dealing with a lame product or if I should save a hassle and go with my tap. Anyone else kept crystals in what is not considered "ideal" params and have them thrive?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome