The Planted Tank Forum - Reply to Topic
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Shrimp & Other Invertebrates > daed shrimps

Thread: daed shrimps Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-12-2012 01:14 AM
gtu2004
Quote:
Originally Posted by jcsdad View Post
looks like it , what are these? is there a fix?
I never came across these but i guess you can google "parasite worm cure"? It's a bad news if they are these. I'd imagine seachem paraguard would work but you should do some research on it a bit before taking my word for it.

EDIT: Oopps, misread as "white worms on shrimps". If it's on the tank itself, then it probably isn't parasite worms. Please disregard my posts...
11-11-2012 07:24 PM
rrastro Also, petco will do free water tests for you until you get proper test equipment. Just bring in a recent sample.
11-11-2012 06:48 PM
somewhatshocked You have to use a product to add minerals to your RO/DI water if you want to house Crystals (or anything, really). Mosura Mineral Plus Ultra, Shirakura Ca+, the Salty Shrimp stuff, et al.

I would encourage you to get GH & KH test kits right away and do some reading about proper shrimp care. Everything is available to you in the stickies here in the shrimp sub-forum.
11-11-2012 04:02 PM
Schkrimpz I don't think that plant nutrients are quite the same thing.. From what I understand (expect me to be wrong) when people use RO water with shrimp they use calcium, magnesium, and other nutrients, to adjust the PH, KH and GH to the right levels for their shrimp. for you to be using RO water with CRS, you really need to be able to test the PH, KH and GH
11-11-2012 03:45 PM
jcsdad
Quote:
Originally Posted by Schkrimpz View Post
He's talking about adding minerals to the RO water. RO water is chemically pure. I would think water without any minerals in it could cause all kinds of deficiencies. Maybe this is the cause of the dead shrimp? Obviously you should wait for somone more experience to chime in. The only experience with RO that I have had is with plant growing, and I know that with plants if you use RO and don't add in any micro nutrients to it, the plants will eventually die from lack of ca/mg/iron etc.
I have some Macro Micro Nutrient Mix from Aquarium Fertilizer.com that I have been using on another tank. Will this work for my dwarf baby tears?

I have also started to treat the tank with No-planaria from GLA. water turned cloudy. used a tablespoon for the whole 60p tank. hope I did not overdose.
11-11-2012 02:52 PM
Schkrimpz
Quote:
Originally Posted by jcsdad View Post
tank was cycled for 2 months, and has been running since February. I do not put anything back in the water when I do water change. Should. i treat for planaria?
He's talking about adding minerals to the RO water. RO water is chemically pure. I would think water without any minerals in it could cause all kinds of deficiencies. Maybe this is the cause of the dead shrimp? Obviously you should wait for somone more experience to chime in. The only experience with RO that I have had is with plant growing, and I know that with plants if you use RO and don't add in any micro nutrients to it, the plants will eventually die from lack of ca/mg/iron etc.
11-11-2012 02:40 PM
jcsdad tank was cycled for 2 months, and has been running since February. I do not put anything back in the water when I do water change. Should. i treat for planaria?
11-11-2012 02:22 PM
jcsdad looks like it , what are these? is there a fix?
11-11-2012 02:20 PM
somewhatshocked They're likely nematodes (harmless), which typically appear in new tanks or in tanks where you overfeed. If they're flat and have triangular heads, they're planaria - they can harm shrimp and can also explode with overfeeding.

How long has your system been set up and running? How long did you cycle the tank?

What product are you using to remineralize your RO water?

If you're keeping Crystals, you'll need to know your water hardness. Pick up a liquid GH & KH kit to test hardness.
11-11-2012 02:07 PM
gtu2004 same as these?

WARNING: graphic

http://www.youtube.com/watch?v=YGxqARvkoJQ
http://www.youtube.com/watch?v=_CuxS...feature=relmfu
11-11-2012 01:54 PM
jcsdad not sure about the hardness, i have CRS and the worms are tiny and white. not easy to take a picture, difficulty focussing the camera. i use RO water if that helps.
11-11-2012 01:39 PM
somewhatshocked What kind of shrimp do you keep?

What's your hardness (GH & KH)? TDS?

Can you tell us more about what the worms look like up close?
11-11-2012 11:21 AM
jcsdad
daed shrimps

for the past 2 mornings, i woke up to see white spots that look like worms on the side of my tank. a short time after i switch the lights on, they are gone. i am afraid that this may be the reason i am finding a dead shrimp or 2 everyday. i tested the water. ammonia 0, nitrite 0, nitrate is .25 if that. my Ph is at 6.4. i have my temp at 75 and all i have in the tank is dwarf baby tears.

has anybody had this problem and what can i do to fix it? open to all suggestions.

thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 08:49 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012