The Planted Tank Forum - Reply to Topic
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Plants > Petsmart live plants (packets) thread

Thread: Petsmart live plants (packets) thread Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-28-2012 06:00 AM
Betta86 Rearranged my tank (added a piece of Mopani), the Crypts from the packets are on both sides, the Anubias came from one of the tubes. All are flourishing.
10-27-2012 09:23 AM
TheKribKeeper Sorry about the double pictures I edited them due to originals being tiny don't know why it doubled them up. Oh well I'm new. Lol
10-27-2012 09:06 AM
TheKribKeeper I bought 2 packs of the cryptocoryne wendtii about 2 weeks ago for my low tech 10 gallon. They are looking good so far. I actually went and bought another pack of them tonight. The ones in back like someone else said looked like they were in the greatest health also. Here is a pic of the first ones i got about 2 weeks old now.



And here is the plant pack I bought tonight.







And in the tank.



Notice how much better the 2 week old ones look compared to the ratty looking new ones thats what they looked like at first. I use just gravel and laterite with a pinch of dry ferts. I think these are great plants compared to the ones in tubes imo.
10-27-2012 04:19 AM
Elppan
Quote:
Originally Posted by SpecGrrl View Post
It grows submersed?

Is it the Joseph's coat variety?

I have some in a riparium trellis, I put it underwater and it started to melt so I took it back out again!
ermmm... Idk? haha check the pic I posted, if you like it I'll send you a few for just shipping, I've got more than I need at the moment!
10-27-2012 02:18 AM
Assassynation I'm planting DHG right now, splitting up the bunches.
10-27-2012 01:47 AM
jspk I bought bacopa and crypts a while back. They are doing real great. The bacopa are in the back and the crypts are the ones on the far left. You can see how much they've grown from an itty bitty packet by the size of my neon tetra.
10-22-2012 09:43 PM
mach_six I shoudl take that back on the emersed, I meant grown in some dirt substrate. The packaging says it's a product of Singapore. I guess they import them so I think it can contain any dirt.

The gel is agar and is edible but I wouldn't recommend it. The bacopa had a lot of black substance stuck in the gel mixed with the root I mistaken it for dirt since the water was murky until I opened it today and cleaned it.
10-22-2012 06:56 PM
SpecGrrl
Quote:
Originally Posted by Elppan View Post
Me! It grows fantastically!
It was actually the only package they'd ever had of it, the top was missing and some of it was dead, so I talked the manager into giving it to me for $1. It took me over 2 hours of googling to find out what it was.
It grows submersed?

Is it the Joseph's coat variety?

I have some in a riparium trellis, I put it underwater and it started to melt so I took it back out again!
10-22-2012 05:49 PM
Brian041
Quote:
Originally Posted by Neatfish View Post
I'm getting ticked off they keep going up on the price of these plants. I'm not going to buy from them anymore if they keep doing that bull stuff.
Check different stores. I work at one. My store sells them for like 8 bucks a tube, while other stores in my district sell them for about 4-5 bucks. I generally try to pull the dead or dying plants off the shelf when I'm covering the department. Granted I tell most people who are really interested in the hobby to check LFS or specialty aquatic plant stores. Much better selection.
10-21-2012 05:47 AM
Neatfish I'm getting ticked off they keep going up on the price of these plants. I'm not going to buy from them anymore if they keep doing that bull stuff.
10-21-2012 05:27 AM
Betta86 Everything should be Top Fin packaging soon, if not already. Out of the two packages I've bought, I haven't had dirt at all. So not sure? As for the suppliers, I have no idea. Most of the aquatic products have switched to Top Fin, which is the store brand. Anything listed under Pacific Dist. is Petsmart.
10-21-2012 03:19 AM
mach_six They must get them from 2 different suppliers? I saw they had teh Top Fin and some generic same packaging of the same plants.

I got the Bacopa and Ludwigia.

Some of them was already mush towards the end, looks like they're all grown emersed from the dirt stuck to it.
10-18-2012 06:34 AM
Betta86 I work at PetSmart and a few months ago when the packs first came out, I bought a pack of crypts. So far, so good! Key is to make sure nothing is decomposing in the packs. The gel is easy to rinse off. The Anubias Nana in the middle is also from PetSmart, from the tube packages. I have a piece of Mopani that is soaking that will eventually be in the tank.

http://s20.photobucket.com/albums/b2...98430294_n.jpg
10-12-2012 08:43 PM
MichaelMcG ya i got dirt with sand cap and a high medium light but its only been like 3 days lol. i did pull one up to move yesterday when i was messing with my filter and it had roots so they should start growing good soon.
10-12-2012 07:23 PM
Elppan
Quote:
Originally Posted by MichaelMcG View Post
thanks Elppan looks good. now i just need mine to grow
It grows pretty quick for me, although I get a little light in that corner of the tank from sun sneaking past my blinds as well as my t5ho, so it could be that. I tore it all apart when I got it, cleaned out all the dead stuff (there was a lot) shoved it in my dirt topped sand and hoped for the best lol. I haven't given it any ferts of anything so far either.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 08:01 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012