The Planted Tank Forum - Reply to Topic
Thread: How soon should I wait until I start... Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
11-14-2011 07:30 AM
Originally Posted by KookScape View Post
Alright. What about tabs near vals and crypts?
Crypts are heavy root feeders - so definitely. Vals will be benefited by root tabs also as they seem to have a pretty extensive root system.
11-14-2011 03:40 AM
KookScape Alright. What about tabs near vals and crypts?
11-14-2011 03:06 AM
i'm a ninja I would go ahead and starts dosing excel. Whenever I start a new tank I start dosing excel the second day, assuming there are plants. You're good to go with the root tabs also, I'd concentrate on getting them around heavy root feeders.
11-14-2011 02:17 AM
How soon should I wait until I start...

How long should I wait until I start dosing excel in my newly setup 140? its been cycling for 2 weeks and is currently moderately planted. Also, can I toss in some root tabs? My bbuddy at the lfs said to wait but I want my tank to start filling out fast.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome