The Planted Tank Forum - Reply to Topic
Thread: DIY for built-in sump filter (Fluval Spec V) Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
09-09-2013 07:38 PM
aquanoob I am puzzling through this same issue with my spec v. Have you tried placing an air stone or limewood diffuser under the filter foam in the sump? I am thinking about doing this... It seems to me that the bubbles would have to fight up through the filter media against the current thus being more efficiently dissolved into the water...
01-01-2013 09:54 AM
DIY for built-in sump filter (Fluval Spec V)

Hey guys,

I have been perusing the DIY forms and am still encountering some issues with figuring out the best system for injecting my DIY CO2 system.

The tank I have is a Fluval Spec V (5G) that has a sump-type filter. This means that an inline reactor is out of the question as there's no canister filter to mess with.

Also, the outake is located near the top of the tank which makes me think is not an ideal choice for diffusing the CO2 throughout the tank.

Any ideas would be much appreciated as to how to most effectively diffuse the CO2 into the tank. Thank you!

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome