The Planted Tank Forum - Reply to Topic
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Algae > API Liquid Algaefix

Thread: API Liquid Algaefix Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-30-2012 10:38 PM
wkndracer One here too.
http://www.plantedtank.net/forums/sh...light=algaefix
11-30-2012 06:47 PM
sessionthree
Quote:
Originally Posted by queball753 View Post
I have a 56 Gal planted tank. I have some algae growing on the leaves of my plants, nothing major. I saw a product at Petco, Algaefix by API. Its a liquid that you pour into the tank. Has anyone used this product? Did it help?
There's an extensive thread about it here at the barrreport (but you have to be a registered subscriber to access it):
http://www.barrreport.com/showthread...lgaefix-by-API

The short answer is that yes, if used according the instructions, it can be effective on a number of types of algae. I used it to knock out a nasty Rhizoclonium infestation once and for all, but I haven't had sucess with it against BBA. Fish and plants don't seem to be bothered by it. Shrimp will need to be removed before using it, though.
11-30-2012 06:25 PM
queball753
API Liquid Algaefix

I have a 56 Gal planted tank. I have some algae growing on the leaves of my plants, nothing major. I saw a product at Petco, Algaefix by API. Its a liquid that you pour into the tank. Has anyone used this product? Did it help?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 01:57 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012