The Planted Tank Forum - Reply to Topic
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Algae > Please help identify :/

Thread: Please help identify :/ Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-22-2011 08:33 AM
tbarabash Looks like some kinda fungus since it's growing away from the stem... leaves look fine, plant color looks fine, I don't think it would be melting.

Got any shrimps? My RCS and amanos eat the hell out of all the fungus I get like that growing in my tanks
11-22-2011 04:28 AM
SexMachineGuns If that is Crypt Melt what should I do about it? Just leave it or try to remove it or the plant?

I do like sex machineguns though I don't listen to them that much... sick guitarists! I am more a fan of their band name tho probably hahaha
11-22-2011 04:06 AM
msjinkzd ha!

<sorry that was not very helpful>
11-22-2011 03:56 AM
Monster Fish It's kind of hard to tell but Im guessing it's crypt melt. Though if the plant was damaged during transit, I believe fungus would grow from damaged areas, but that is just a wild guess. Clearer pics would be nice.

Also are you by any chance a Sex Machineguns fan?
11-22-2011 03:40 AM
SexMachineGuns
Please help identify :/

Hey guys i'm new in this forum and new to this hobby! So what up everyone?

Anyways, got this weird white stuff growing near the roots of my crypt parva and on some of leaves as well not sure if its some kind of algae or some fungus or something so please help me out. There's more appearing on my other crypt parva as well but its not coming out clear so I didn't upload that one.

I know the picture isn't that clear I used my phone to take the picture, I can try to take some more later if needed.

Any thoughts?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 09:28 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012