The Planted Tank Forum - View Profile: whistlerskipro

whistlerskipro whistlerskipro is offline

Algae Grower

  Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. whistlerskipro
    04-08-2014 09:52 PM - permalink
    whistlerskipro
    My heavily planted 80g freshwater aquarium is need of some assistance. Though my water is clear, when I do a water change the water in a white bucket will appear blue green. This tank has been cycled for 1.5 years but I feel I may be guilty of overfeeding and too much light. It's been 24 hours since I have covered up my aquarium completely from light but have heard that it could be covered for as little as 48 hours to 5 days, without feeding as well and the temp lowered to 25 cel. Has anyone used this natural method of killing algae? I just purchased the current USA LED PLUS. and plan on doing a 1/2 water change when complete and clean out my 303 canister filter. I do not run any Co, and my tank is inhabited with 1 Angel-1 Raphael-4-cory 5-rummynose 8-assorted rasboras. I definitely consider myself a novice and would appreciate any feedback. I hope I am posting this in the right location, but have a feeling if I am not, I will find out soon. Thanks Pete

  About Me

  • About whistlerskipro
    Location
    British Columbia

  Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 06-13-2014 02:36 AM
  • Join Date: 04-08-2014
  • Referrals: 0

  Mentions

No results to display...

  Quotes

No results to display...

  Feedback Score

iTrader Profile Recent Ratings
Feedback Score:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
Submit Feedback
  Past
Month
Past
6 Months
Past
12 Months
Positive Positive 0 0 0
Neutral Neutral 0 0 0
Negative Negative 0 0 0
 
For the best viewing experience please update your browser to Google Chrome