CO2 Bubble counter/check valve clogged - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 03-06-2014, 03:29 AM Thread Starter
Algae Grower
 
Join Date: Jan 2014
Location: Los Angeles, CA
Posts: 10
CO2 Bubble counter/check valve clogged

I just set up my paintball canister CO2 system. I purchased a bubble counter off of ebay:

[Ebay Link Removed]

and I have it hooked up to my aquatic life CO2 regulator, but it will not let CO2 pass through. When I hook up the tubing directly to the regulator without the bubble counter, CO2 passes through easily. What could be wrong with the bubble counter? Do I need to return it and get a new one?
Thanks!
hchu182 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 03-06-2014, 03:38 AM
Planted Tank Guru
 
FlyingHellFish's Avatar
 
Join Date: Nov 2011
Location: Canada
Posts: 2,388
You hook it like this:



o ring goes on the needle valve, then you screw on the bubble counter


Then you sit back and admire how sexy it looks.



ADA 60P
|ADA 60F|ADA 30C|Fluval Edge[6g] |DIY Diffuser YT
E-series E60 on ADA60F - MicMol AquaMini x3 on ADA 60P - MicMol AquaPro on ADA30C
FlyingHellFish is offline  
post #3 of 9 (permalink) Old 03-06-2014, 03:46 AM Thread Starter
Algae Grower
 
Join Date: Jan 2014
Location: Los Angeles, CA
Posts: 10
So when I try setting it up like that, CO2 will not pass through the bubble counter. It's as if the part that connects tot he regulator is clogged or blocked.
hchu182 is offline  
post #4 of 9 (permalink) Old 03-06-2014, 04:00 AM
Planted Tank Guru
 
FlyingHellFish's Avatar
 
Join Date: Nov 2011
Location: Canada
Posts: 2,388
Could you take a pic of the set up, maybe its a diff bc?



ADA 60P
|ADA 60F|ADA 30C|Fluval Edge[6g] |DIY Diffuser YT
E-series E60 on ADA60F - MicMol AquaMini x3 on ADA 60P - MicMol AquaPro on ADA30C
FlyingHellFish is offline  
post #5 of 9 (permalink) Old 03-06-2014, 07:21 AM Thread Starter
Algae Grower
 
Join Date: Jan 2014
Location: Los Angeles, CA
Posts: 10
http://imgur.com/REjCza7

http://imgur.com/0caEwez

Here's how it is set up. I have a slightly different bubble counter, but it should work the same way. when I the solenoid is on and I turn the knob on the regulator to fully open, no bubbles will form in the chamber. Do I have to wait?
hchu182 is offline  
post #6 of 9 (permalink) Old 03-06-2014, 09:28 AM
Planted Tank Guru
 
FlyingHellFish's Avatar
 
Join Date: Nov 2011
Location: Canada
Posts: 2,388
Oh, wait wait a minute! Where in the world did you get a green Aquatic Life regulator? That looks great!

That the same bubble counter except it's made for "in-line", and you won't need that o-ring, actually I don't think it even comes with one.

Anyways, have you tried turning the needle valve up? Not too much, just turn a bit and wait, turn a bit and wait, you get the idea.


When the solenoid comes on, it should be producing bubbles in the first 5 second. If not, then you got something clogging it. And if it doesn't get any bubble, then there a huge leak or it doesn't have the required working pressure to "crack" the built in check valve, which I highly doubt that the case.

Oh yo, you sure the nut on the bottom of that bubble counter is screwed on right? It should be completely alined with the bubble counter. Yours is on an angle. First, make sure those screws are set right. If that doesn't work, use a longer tubing and test again. <- Better advice.



ADA 60P
|ADA 60F|ADA 30C|Fluval Edge[6g] |DIY Diffuser YT
E-series E60 on ADA60F - MicMol AquaMini x3 on ADA 60P - MicMol AquaPro on ADA30C
FlyingHellFish is offline  
post #7 of 9 (permalink) Old 03-07-2014, 03:57 AM Thread Starter
Algae Grower
 
Join Date: Jan 2014
Location: Los Angeles, CA
Posts: 10
thanks for the response. it is actually blue like yours, i think it's just the lighting from my tank makes it look green.

I've tightened all the screws and tubes and I think the problem is the check valve portion of the counter must be clogged or the working pressure isn't enough to break through which like you said would be odd.

with the bubble counter completely off, when i turn the knob on the regulator, i can hear co2 escaping. if i take apart the bubble counter and just place the check valve portion, i.e. the bottom part of the counter, on to the regulator and open the knob, i cannot hear any CO2 escaping
hchu182 is offline  
post #8 of 9 (permalink) Old 03-07-2014, 05:10 AM
Planted Tank Guru
 
FlyingHellFish's Avatar
 
Join Date: Nov 2011
Location: Canada
Posts: 2,388
That is a bit odd, it should be able to push the Co2 through. Try this, without the bubble counter connected, put the Co2 tubing in a glass of water and aim for 2 - 3 bps. Reconnect the bubble counter and use a longer tubing, 1 feet should be fine.

Wait 15 mins and check on the bubble counter, if it's still not going then disconnect the bubble counter because then it's a pressure issue.

a. Not enough working pressure to break the check valve
b. Leak at the connection that reduces the working pressure
c. Check valve is clog and requires a higher working pressure
d. Typical cheap bubble counter from asia with no quality control

Let me know how the bps is on the regulator, we can at least make sure it's working and can concentrate on the bubble counter. Luckily for you, I have the same setup, I'll let you know how much psi it requires to push bubbles through. I got those bubble counters on another regulator set up with adjustable pressure settings.



ADA 60P
|ADA 60F|ADA 30C|Fluval Edge[6g] |DIY Diffuser YT
E-series E60 on ADA60F - MicMol AquaMini x3 on ADA 60P - MicMol AquaPro on ADA30C
FlyingHellFish is offline  
post #9 of 9 (permalink) Old 03-08-2014, 06:34 AM
Planted Member
 
mfurufuru's Avatar
 
Join Date: Mar 2012
Location: oahu
Posts: 246
+1 I agree. I'd say it might be a leak somewhere.
Try some soap on the connecting points. I used some teflon tape to seal my co2 connectors.

Quote:
Originally Posted by FlyingHellFish View Post
That is a bit odd, it should be able to push the Co2 through. Try this, without the bubble counter connected, put the Co2 tubing in a glass of water and aim for 2 - 3 bps. Reconnect the bubble counter and use a longer tubing, 1 feet should be fine.

Wait 15 mins and check on the bubble counter, if it's still not going then disconnect the bubble counter because then it's a pressure issue.

a. Not enough working pressure to break the check valve
b. Leak at the connection that reduces the working pressure
c. Check valve is clog and requires a higher working pressure
d. Typical cheap bubble counter from asia with no quality control

Let me know how the bps is on the regulator, we can at least make sure it's working and can concentrate on the bubble counter. Luckily for you, I have the same setup, I'll let you know how much psi it requires to push bubbles through. I got those bubble counters on another regulator set up with adjustable pressure settings.
mfurufuru is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome