fixing my lily pipe - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 11-06-2013, 10:53 PM Thread Starter
Algae Grower
PTrader: (4/100%)
Join Date: Aug 2013
Location: Brooklyn
Posts: 30
fixing my lily pipe

I broke the suction cup holder part of the glass off of my lily pipe. It took part of the tube with it but it seems like it basically is an intact piece. What is the best way to reattach it seamlessly? Thanks
throughthisvalley is offline  
Sponsored Links
post #2 of 5 (permalink) Old 11-06-2013, 11:13 PM
Darkblade48's Avatar
PTrader: (3/100%)
Join Date: Jan 2008
Location: Toronto/Singapore
Posts: 9,805
Do you have a picture?

I do not think there is any way to reattach the broken piece seamlessly unless you reblow the broken pieces. If you are looking to reattach it though, silicone would be my first option.


A Primer to Pressurized CO2 and A Primer to Planted Tanks
Eheim Pimp #362 - Eheim 2213 x2, Eheim 2028, Eheim 2217, Eheim surface skimmer and Eheim autofeeder.
Victor Pimp #33 - HPT272-125-350-4M
Darkblade48 is offline  
post #3 of 5 (permalink) Old 11-06-2013, 11:31 PM
Wannabe Guru
exv152's Avatar
PTrader: (0/0%)
Join Date: Jun 2009
Location: Canada
Posts: 1,804
Same thing happened to me, and I ended up getting a new lily pipe in the end. Where the suction cup came off, it took a chunk of glass with it and left tiny cracks. So I didn't trust it would stay intact for too long and didn't want to risk it.

Eheim Pimp Club,# 496
25g 60-P iwagumi , 33g iwagumi cube, 125g high tech 7g cube, 75g low tech angelfish tank
exv152 is offline  
post #4 of 5 (permalink) Old 11-06-2013, 11:44 PM Thread Starter
Algae Grower
PTrader: (4/100%)
Join Date: Aug 2013
Location: Brooklyn
Posts: 30
I was thinking something rigid like epoxy. It didn't crack just pulled away. I guess I mean fairly seamless, no silicon chunks.
throughthisvalley is offline  
post #5 of 5 (permalink) Old 11-07-2013, 12:06 AM
Planted Tank Obsessed
PTrader: (0/0%)
Join Date: May 2013
Location: Eugene, Oregon
Posts: 304
Glass does not glue well. Even "glass" glues don't really work. The only thing I know of is an epoxy that you use a uv light to set and I don't think its really worth it for a single pipe. Silicone would be a next best that I know of.
Tzac is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome