Need CO2 help - The Planted Tank Forum

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 10-05-2013, 04:09 AM Thread Starter
Planted Member
 
Join Date: Jul 2013
Location: NJ
Posts: 234
Need CO2 help

Swapped empty tank for new, employee at store detached/reattached regulator under my auspices.

Opened CO2 at my home, it's now shooting out of the hole in the attached pic, this small keyhole. That's an adjustment screw? This phenomenon is new to me...

Please help/advise. Is this a matter of tightening (I tried) or is something amiss? Thanks guys.
Attached Thumbnails
Click image for larger version

Name:	IMG-20131004-00149.jpg
Views:	57
Size:	80.8 KB
ID:	217057  

BigL_RIP is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 10-05-2013, 04:17 AM Thread Starter
Planted Member
 
Join Date: Jul 2013
Location: NJ
Posts: 234
there's a small pinhole inside that larger orifice there.
BigL_RIP is offline  
post #3 of 10 (permalink) Old 10-05-2013, 05:00 AM
Planted Tank Guru
 
ua hua's Avatar
 
Join Date: Oct 2009
Location: Nebraska
Posts: 2,463
It's releasing from your relief valve and probably because you had your low pressure gauge open when you opened the valve on the tank. You need to always have your knob on the regulator turned all the way counter clockwise when you hook it up to a new co2 cylinder then open up the co2 tanks valve then after that you turn the knob on your regulator clockwise to set working pressure.

Is your low pressure gauge still working or did it blow it?

All matter is merely energy condensed to a slow vibration, we are all one consciousness experiencing itself subjectively, there is no such thing as death life is only a dream which is an imagination of ourselves. Bill Hicks
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
ua hua's 90 gal. high tech
ua hua's 5,000 gal. water garden
ua hua is offline  
post #4 of 10 (permalink) Old 10-05-2013, 05:26 AM
OVT
Carpe Diem
 
OVT's Avatar
 
Join Date: Nov 2011
Location: NorCal
Posts: 5,605
^+1

v3

Courtesy * Integrity * Perseverance * Indominable Spirit * and Self Control
Tenets of TKD
OVT is offline  
post #5 of 10 (permalink) Old 10-05-2013, 06:04 AM Thread Starter
Planted Member
 
Join Date: Jul 2013
Location: NJ
Posts: 234
nothing is is registering with the regulator plugged in; in fact one needle is pointing toward no digit in particular; it's past the zero rest. So I guess that's an affirmative on the blown gauge? I need a new regulator?
BigL_RIP is offline  
post #6 of 10 (permalink) Old 10-05-2013, 05:14 PM
Moderator
 
Darkblade48's Avatar
 
Join Date: Jan 2008
Location: Toronto/Singapore
Posts: 10,297
Sounds like you blew a gauge.

You do not need a new regulator, just a new gauge.

Anthony

A Primer to Pressurized CO2 and A Primer to Planted Tanks
Eheim Pimp #362 - Eheim 2213 x2, Eheim 2028, Eheim 2217, Eheim surface skimmer and Eheim autofeeder.
Victor Pimp #33 - HPT272-125-350-4M
Darkblade48 is offline  
post #7 of 10 (permalink) Old 10-05-2013, 05:35 PM Thread Starter
Planted Member
 
Join Date: Jul 2013
Location: NJ
Posts: 234
Thanks guys, I appreciate it. A lesson in not doing something in the middle of the night.

So the regulator will still function wihile I replace the gauge?
BigL_RIP is offline  
post #8 of 10 (permalink) Old 10-08-2013, 03:19 AM
Planted Member
 
John Simpson's Avatar
 
Join Date: Mar 2013
Location: Honolulu
Posts: 278
Quote:
Originally Posted by BigL_RIP View Post
Thanks guys, I appreciate it. A lesson in not doing something in the middle of the night.

So the regulator will still function wihile I replace the gauge?
that's a good question does the regulator function without the gauge? it just doesn't read the pressure? I'm not really sure what I would do here
John Simpson is offline  
post #9 of 10 (permalink) Old 10-08-2013, 03:38 AM
Planted Tank Enthusiast
 
Join Date: Jul 2013
Location: Kaneohe, Hawaii
Posts: 548
You'd need to plug the gauge port but the regulator would still work. You couldn't tell what your output pressure was either.
Lornek8 is offline  
post #10 of 10 (permalink) Old 10-09-2013, 12:55 AM Thread Starter
Planted Member
 
Join Date: Jul 2013
Location: NJ
Posts: 234
I simply left things as is and the CO2 is disbursing normally, monitoring output by eye as I did previously. So far, no problems. Will ride with it as is if things stay this current course.
BigL_RIP is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome