Regulator issues - help needed - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-05-2013, 05:52 PM Thread Starter
Planted Member
 
Join Date: Mar 2012
Location: New York
Posts: 150
Regulator issues - help needed

For some reason lately my regulator had been acting funny. Upon start up it seems that the bubbles are barely trickling out at the bubble counter. In order for me to get things flowing I have to kick up the working pressure to about 40psi. Sometimes it works and then other times its as if the pressure is lost and the bubbles start to trickle out again at the bubble counter. Any ideas? Is my regulator busted? My needle valve?
kroner19 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-05-2013, 06:00 PM
Planted Tank Enthusiast
 
Join Date: Sep 2012
Location: Sacramento, CA
Posts: 765
My working pressure is always 40 psi. you are using a needle valve as well correct?
puopg is offline  
post #3 of 4 (permalink) Old 05-05-2013, 06:05 PM
Algae Grower
 
oldpunk78's Avatar
 
Join Date: Nov 2008
Location: Anderson, CA
Posts: 6,381
I would check to see if your difffuser is clogged or if you have developed a leak somewhere in the line going to it.

What would Honey Badger do?
oldpunk78 is offline  
post #4 of 4 (permalink) Old 05-05-2013, 06:35 PM
Planted Tank Guru
 
Bettatail's Avatar
 
Join Date: Feb 2009
Location: San Francisco
Posts: 2,530
Quote:
Originally Posted by kroner19 View Post
For some reason lately my regulator had been acting funny. Upon start up it seems that the bubbles are barely trickling out at the bubble counter. In order for me to get things flowing I have to kick up the working pressure to about 40psi. Sometimes it works and then other times its as if the pressure is lost and the bubbles start to trickle out again at the bubble counter. Any ideas? Is my regulator busted? My needle valve?
check leak, especially under the bubble counter where it connects to the metal fitting.

if no leak, up the output pressure at around 40 psi.
Bettatail is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome