110g for $500 - Page 2 - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #16 of 17 (permalink) Old 05-04-2013, 06:24 AM
Wannabe Guru
Kitsune_Gem's Avatar
Join Date: Apr 2012
Location: San Ramon, Ca
Posts: 1,041
Send a message via Skype™ to Kitsune_Gem
That red stuff is a form of marine algae (Most of the time, its rare when I come across it in fresh) its a pain in the A** to get off fresh or marine wise

"And 5, very important 5... Don't let me eat pears.. I HATE PEARS."
Kitsune_Gem is offline  
Sponsored Links
post #17 of 17 (permalink) Old 05-04-2013, 12:54 PM
Planted Member
Join Date: Dec 2011
Location: Raleigh, NC
Posts: 225
Originally Posted by Indychus View Post
$250 for just the tank or for stand also? That still sounds high to me. Around here I can pick up a new 125 for $2-300.
Wow, where at? I am in NC and been looking for 125 and here around Raleigh area, brand new 125, is around 800. I have hit every LFS within 30 mile range.

Yes 500 for that 110 is way to much.
marcnc is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome