Extra Ebo Jagers by mistake - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-29-2003, 04:57 PM Thread Starter
Planted Tank Enthusiast
Scorpion's Avatar
Join Date: Oct 2003
Location: Olympia, WA
Posts: 637
Do I feel like an idiot! I noticed that the temp on my 55 was around 72-73 all day yesterday. After messing with the controls on and off, I ordered 2 Ebos 250 watts for around 16 dollars a pc. I had come to the conclusion that the heater was going bad. Well... I was messing with the unit again when the wife called about 15 minutes ago. I broke the news that I ordered 2 Ebos since they were reasonably cheap She had to go so we said good byes to each other. I went back to messing with the heater just to find out that it was unplugged!!!!!!!!!! Yes! UNPLUGGED! ops: :stupid:

Now I have to call her and tell her that I feel like an idiot ops: :lol: ops: I must have unplugged the heater when I was working on the tank a few weeks back. The bonus: I have two extra Ebos than can now serve as back ups The moral: check to see if it is unplugged before calling the repairman! ops:

Has anyone else had a similar experience? :roll:
Come on! Donít be shy!

ESTJ (v)
EPC Member #27
Scorpion is offline  
Sponsored Links
post #2 of 4 (permalink) Old 10-29-2003, 05:12 PM
Are these real?
Wasserpest's Avatar
Join Date: Jun 2003
Location: Monterey, CA
Posts: 15,385
Isn't there like a little light that turns on when the heater is on? I am not familiar with this brand, just keep hearing they are the best. I love my via aqua titanium tube... it has a separate electronic control unit with a big big dial to easily choose the right temp. Also a separate temp sensor. And not made out of glass. And $12 for the 150W model.
After that I bought a "compact heater" which flips a little metal spring back and forth, and I hate it... hard to get the right temperature, and due to its mechanical nature it is not very exact, and might get stuck anytime. Oh yeah, and more expensive than the via aqua. Not such a good purchase.

BTW... can't you cancel your order?

I have my share of experiences like that. Like buying another coffee machine which stopped working too, until I figured out that I need to run vinegar through it every so often. Or, trying to heat up some pizza. Set the timer, but forgot to turn on the oven. After 25 minutes took it out and it is still cold! Okay, set the timer again, this time turning on the oven. After 25 minutes looking inside, well, nothing inside. Remember I took it out but didn't put it back in :lol: No... I don't know what that has to do with heaters.
Wasserpest is offline  
post #3 of 4 (permalink) Old 10-29-2003, 05:18 PM Thread Starter
Planted Tank Enthusiast
Scorpion's Avatar
Join Date: Oct 2003
Location: Olympia, WA
Posts: 637
The unit that I was "trying" to replace is a no brand from petsmart. I really do not want to cancel the order b/c I need to have a back up. Besides that, this will be my first Ebo units that I own. And the light is working on that ole heater.

ESTJ (v)
EPC Member #27
Scorpion is offline  
post #4 of 4 (permalink) Old 10-31-2003, 12:43 PM
Wannabe Guru
Join Date: Oct 2002
Location: Houston, TX
Posts: 1,614
Yeah, I've done that. I ordered a second hagen CO2 unit along with some stuff I needed, then added it to the order again, failed to notice that I had 2 on the order until after I submitted it and it had been shipped. Eventually I needed that 3rd unit, though, so I could match pH between the main tank and a Q tank. So, don't worry, one day you'll be glad you have that new spare.
anonapersona is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Any extra parts needed to connect reactor to Eheim outtake? wonder woman Equipment 5 05-26-2004 10:34 PM
desklamp for extra lighting mjprather Lighting 1 04-24-2004 07:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome