New filter smell. - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-23-2013, 08:26 PM Thread Starter
Planted Tank Enthusiast
Sugardaddy1979's Avatar
PTrader: (12/100%)
Join Date: Jan 2012
Location: Athens, GA
Posts: 642
New filter smell.

I got a new eheim 2213 and my water now smells plastic like. Like the new hoses. Is that normal/ dangerous?

Sunsun Pimp Club Member #068
Sugardaddy1979 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 03-23-2013, 11:23 PM
Wannabe Guru
PTrader: (2/100%)
Join Date: Jun 2005
Location: Medina, Ohio
Posts: 1,046
Did you rinse the filter components and media with plain water before installing it?

It is common to have a new plastic smell on new equipment so it shouldn't be a problem.

Eheim Pimpette #270
Eheim Pro II 2028; Classics Series -2215, 2217, 2260, 2262; Pro 2229 Wet/Dry
deeda is offline  
post #3 of 3 (permalink) Old 03-24-2013, 03:47 AM
Planted Tank Obsessed
Yankee's Avatar
PTrader: (4/100%)
Join Date: Jan 2013
Location: Oregon
Posts: 324
That normally happens when you don't rinse the filter basket (and media) out. It could also just be the hoses were set out in the warm too long and it's taking a while for the smell to die out. It'll go away once your filter gets enough gunk in it.
Yankee is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome