Knock off canister filter losing prime - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-02-2013, 12:52 AM Thread Starter
Planted Member
Join Date: Oct 2012
Location: New York City
Posts: 260
Knock off canister filter losing prime

I have a Chinese knock off Sun Sun canister filter with UV. Every couple of days it loses prime. It has no skimmer and all the intake hoses seem to be tight. I have to pump the prime button every other day to get it started again. Anyone else have this problem?
Shangrila is offline  
Sponsored Links
post #2 of 4 (permalink) Old 03-02-2013, 12:54 AM
Wannabe Guru
samee's Avatar
Join Date: Oct 2011
Location: Canada & US
Posts: 1,004
Ive had this filter for maybe 2 years now, no problems yet, very quiet.
samee is offline  
post #3 of 4 (permalink) Old 03-02-2013, 01:27 AM
Planted Tank Obsessed
Join Date: Sep 2012
Location: TX
Posts: 474
Sounds like you probably have a leak at the seal.
sarahspins is offline  
post #4 of 4 (permalink) Old 03-02-2013, 01:14 PM
Algae Grower
Join Date: Jan 2013
Location: Georgia
Posts: 115
I have a SunSun 302 and I am battling the same problem. Although mine is about 2 weeks old! Has me rethinking ever getting a canister filter again.
pastert33 is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome