Problems with Filter - Page 2 - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #16 of 18 (permalink) Old 10-01-2003, 04:55 PM Thread Starter
Algae Grower
PTrader: (0/0%)
Join Date: Sep 2003
Location: Georgia
Posts: 38
Send a message via AIM to Ollieo83
okay that works, thanks for the info. Are there any good books, or websites on photosynthesis (I am on the topic in Bio 111 and it would be helpful to have a geater understanding of such material) As Thanks!!!

Ollieo83 is offline  
Sponsored Links
post #17 of 18 (permalink) Old 10-02-2003, 04:28 AM
Planted Tank Enthusiast
2la's Avatar
PTrader: (0/0%)
Join Date: Aug 2002
Location: Portland, OR
Posts: 993
2la is offline  
post #18 of 18 (permalink) Old 10-02-2003, 05:36 AM
PTrader: (0/0%)
Join Date: Oct 2003
Posts: 2

It seems everyone with a Penguin complains about the same thing... Me included. I have a 29 gallon with a Penguin 170 and the exact same thing happens to me.

It seems to be a design flaw in the filter. When the filter pad gets a slight amount of waste on it, the water flow is so reduced that (1) the biowheel stops turning, and (2) the water backs up and overflows around the top of the intake tube. I have to replace the filter cartridge (or wash the junk off) about every 9-10 days, sometimes sooner. Ridiculous!
Bird is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Undergravel filter : Am I crazy? Ianice Berg General Planted Tank Discussion 5 09-10-2004 09:12 PM
Mod. a H.O.T. Magnum/diatom filter....? fedge Equipment 28 08-30-2004 12:00 PM
Woodshrimps and Diatom filter macbrush Equipment 6 07-21-2004 01:08 PM
How to Prime a Filter anonapersona Equipment 2 02-01-2004 07:47 PM
Undergravel filter and large rock question. oe254 Equipment 18 01-02-2004 03:07 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome