parker h3l needle valve problem - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-31-2013, 11:50 AM Thread Starter
Algae Grower
 
bababooey's Avatar
 
Join Date: Nov 2011
Location: Atlanta, GA
Posts: 141
parker h3l needle valve problem

I have a parker h3l needle valve that I may have broken somehow... -_-

Q: Parker H3L HR Serie Meter Valve
(This is a picture of the needle valve)

Last night, I was adjusting the valve and the top piece of the meter (smaller knob) came loose while I was turning it and came off the unit. Underneath, there is this metal ring with a notch and if i put the small knob back on, there is a small metal indention that fits snugly into the groove and will turn the metal ring.

Anyway, after the knob came off, I was able to put it back on and turn the meter like normal. It still clicks like normal and the larger meter spins as I turn the smaller knob. HOWEVER, its not adjusting the valve anymore. I tried to turn it all the way off and it was the same bps....then I tried to turn it all the way up and it was the same bps. The working pressure is set at 15 psi and I have a solenoid on a timer. Everything is still working right now except I just can't adjust anything...

So...did I just break the valve somehow or is there something I'm missing here?
bababooey is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-31-2013, 01:51 PM
Wannabe Guru
 
exv152's Avatar
 
Join Date: Jun 2009
Location: Canada
Posts: 1,831
Did you keep the instruction manual that came with the valve? I think I might still have mine at home, and it basically goes over all the steps to install the knob etc. If not, I can check my manual and post back later tonight when I get home, but my first instinct is you may not have installed the knob correctly.

Eheim Pimp Club,# 496
25g 60-P iwagumi , 33g iwagumi cube, 125g high tech, 7g cube, 12g long
exv152 is offline  
post #3 of 5 (permalink) Old 01-31-2013, 02:48 PM
Algae Grower
 
oldpunk78's Avatar
 
Join Date: Nov 2008
Location: Anderson, CA
Posts: 6,391
Did you tighten the set screws down after you put the knob back on? It came with a little Allen wrench that fits those set screws.
oldpunk78 is offline  
post #4 of 5 (permalink) Old 01-31-2013, 05:41 PM Thread Starter
Algae Grower
 
bababooey's Avatar
 
Join Date: Nov 2011
Location: Atlanta, GA
Posts: 141
Quote:
Originally Posted by oldpunk78 View Post
Did you tighten the set screws down after you put the knob back on? It came with a little Allen wrench that fits those set screws.
AHHHHH, that fixed it. I guess the knob wasn't turning the valve because, duh, it was loose. BTW oldpunk, thanks again for helping me build my co2 regulator. I couldn't have done it without you!
bababooey is offline  
post #5 of 5 (permalink) Old 01-31-2013, 07:03 PM
Algae Grower
 
oldpunk78's Avatar
 
Join Date: Nov 2008
Location: Anderson, CA
Posts: 6,391
No problem. Glad to help
oldpunk78 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome