Help! Atomic Bubble Counter not working - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 01-06-2013, 03:48 AM Thread Starter
Planted Tank Guru
 
Axelrodi202's Avatar
 
Join Date: Jul 2008
Location: Morris County, NJ
Posts: 2,590
Help! Atomic Bubble Counter not working

My atomic bubble counter isn't working. My system consists of a paintball tank, paintball adapter, GLA atomic regulator v3, atomic bubble counter w/ integrated check valve and atomic diffuser w/ check valve. When I turn the gas on the gas is flowing, but is unable to get past the bubble counter. No gas bubbles appear in the bubble counter. When I take the bubble counter off I can feel gas coming out from the tubing. How do I remedy this?

O_o
/ /_______________________________
| BWAAAH IMA FIRIHN MA LAZER!!!!!!!!!
\_\
Axelrodi202 is online now  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 01-06-2013, 04:10 AM Thread Starter
Planted Tank Guru
 
Axelrodi202's Avatar
 
Join Date: Jul 2008
Location: Morris County, NJ
Posts: 2,590
Also it appears that the gas only flows when I open the needle valve to the point where there is some gas coming out from the needle valve (or at least I hear the sound of gas leaving). Is this normal?

O_o
/ /_______________________________
| BWAAAH IMA FIRIHN MA LAZER!!!!!!!!!
\_\
Axelrodi202 is online now  
post #3 of 10 (permalink) Old 01-06-2013, 04:38 AM
Moderator
 
Darkblade48's Avatar
 
Join Date: Jan 2008
Location: Toronto/Singapore
Posts: 10,137
Quote:
Originally Posted by Axelrodi202 View Post
Also it appears that the gas only flows when I open the needle valve to the point where there is some gas coming out from the needle valve (or at least I hear the sound of gas leaving). Is this normal?
It sounds like you have a leak somewhere in the system.

I would double check all your connections with some soapy water to see where the leak is first, and then try to tighten that connection.

Anthony

A Primer to Pressurized CO2 and A Primer to Planted Tanks
Eheim Pimp #362 - Eheim 2213 x2, Eheim 2028, Eheim 2217, Eheim surface skimmer and Eheim autofeeder.
Victor Pimp #33 - HPT272-125-350-4M
Darkblade48 is offline  
post #4 of 10 (permalink) Old 01-06-2013, 04:52 AM Thread Starter
Planted Tank Guru
 
Axelrodi202's Avatar
 
Join Date: Jul 2008
Location: Morris County, NJ
Posts: 2,590
The gas is coming from the needle valve. Whenever I open up the needle valve enough to allow for the gas to flow, I start to hear the leaking. When I tighten the needle valve to the point where I can't hear the leaking anymore, the flow of gas stops.

O_o
/ /_______________________________
| BWAAAH IMA FIRIHN MA LAZER!!!!!!!!!
\_\
Axelrodi202 is online now  
post #5 of 10 (permalink) Old 01-06-2013, 06:32 AM
Moderator
 
Darkblade48's Avatar
 
Join Date: Jan 2008
Location: Toronto/Singapore
Posts: 10,137
Quote:
Originally Posted by Axelrodi202 View Post
The gas is coming from the needle valve. Whenever I open up the needle valve enough to allow for the gas to flow, I start to hear the leaking. When I tighten the needle valve to the point where I can't hear the leaking anymore, the flow of gas stops.
I suppose you are using this?

http://greenleafaquariums.com/co2-bu...e-counter.html

Are you sure the tubing connecting the needle valve and bubble counter is on securely?

If you can hear gas flowing out when you open the needle valve, then you probably have a leak.

Anthony

A Primer to Pressurized CO2 and A Primer to Planted Tanks
Eheim Pimp #362 - Eheim 2213 x2, Eheim 2028, Eheim 2217, Eheim surface skimmer and Eheim autofeeder.
Victor Pimp #33 - HPT272-125-350-4M
Darkblade48 is offline  
post #6 of 10 (permalink) Old 01-06-2013, 06:49 AM
Planted Member
 
Join Date: Aug 2011
Location: Los Angeles, CA
Posts: 204
Is this your first time using this system? The connection to the tube is not the best and took me awhile to figure out why I heard a hissing as well. Your tube might not be sitting properly in the connection. I really had to push it in to make it snap into place.
akpoly is offline  
post #7 of 10 (permalink) Old 01-06-2013, 03:36 PM Thread Starter
Planted Tank Guru
 
Axelrodi202's Avatar
 
Join Date: Jul 2008
Location: Morris County, NJ
Posts: 2,590
I've pushed the tubing into the needle valve connection as far as it'll go, and am still experiencing the leaking problem. It appears that the leaking is coming from the part of the needle valve where you turn it to control how tight it is.

O_o
/ /_______________________________
| BWAAAH IMA FIRIHN MA LAZER!!!!!!!!!
\_\
Axelrodi202 is online now  
post #8 of 10 (permalink) Old 01-06-2013, 04:08 PM
Algae Grower
 
oldpunk78's Avatar
 
Join Date: Nov 2008
Location: Anderson, CA
Posts: 6,381
Quote:
Originally Posted by Axelrodi202 View Post
I've pushed the tubing into the needle valve connection as far as it'll go, and am still experiencing the leaking problem. It appears that the leaking is coming from the part of the needle valve where you turn it to control how tight it is.
Contact Orlando.
oldpunk78 is offline  
post #9 of 10 (permalink) Old 01-06-2013, 04:47 PM Thread Starter
Planted Tank Guru
 
Axelrodi202's Avatar
 
Join Date: Jul 2008
Location: Morris County, NJ
Posts: 2,590
I did and he suggested pushing it in further. So I did so and now everything works. Turns out it takes quite an amount of pushing to get it in all the way.

O_o
/ /_______________________________
| BWAAAH IMA FIRIHN MA LAZER!!!!!!!!!
\_\
Axelrodi202 is online now  
post #10 of 10 (permalink) Old 01-06-2013, 05:10 PM
Algae Grower
 
oldpunk78's Avatar
 
Join Date: Nov 2008
Location: Anderson, CA
Posts: 6,381
Quote:
Originally Posted by Axelrodi202 View Post
I did and he suggested pushing it in further. So I did so and now everything works. Turns out it takes quite an amount of pushing to get it in all the way.
I've noticed that if you're having an issue with a gla product, the fastest solution is just to send Orlando an email or if he's active one ape to pm him there.
oldpunk78 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome