Gravel vac not working - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 12-11-2012, 03:04 AM Thread Starter
Wannabe Guru
Join Date: Oct 2012
Location: hawaii
Posts: 1,106
Gravel vac not working

Hi everyone, i just tried to clean my tank today and for some odd reason the vac wouldn't pick up the fish poo? Nothing is blocking the tube and this has never happened before, i also tried to suc up poo from my other tank and it worked just fine.

This is the brand i'm using
fishkeeper01 is online now  
Sponsored Links
post #2 of 9 (permalink) Old 12-11-2012, 03:14 AM
Planted Tank Enthusiast
Big O's Avatar
Join Date: Jun 2011
Location: KCMO
Posts: 884
I don't even own one

Do you have a planted tank?
Big O is offline  
post #3 of 9 (permalink) Old 12-11-2012, 03:24 AM Thread Starter
Wannabe Guru
Join Date: Oct 2012
Location: hawaii
Posts: 1,106
well i was about to set mine up so i took all the fish and clay pots out. And since there was only sand and poo so i decided to clean it up, but then the vac wouldn't suck it up(only a little was actually sucked up).
fishkeeper01 is online now  
post #4 of 9 (permalink) Old 12-11-2012, 06:01 AM
Planted Tank Enthusiast
thebuddha's Avatar
Join Date: Jul 2012
Location: NW Indiana
Posts: 623
must be some dense poo
thebuddha is offline  
post #5 of 9 (permalink) Old 12-11-2012, 11:04 AM
Planted Tank Guru
Join Date: May 2009
Location: MICHIGAN
Posts: 3,239
Maybe you had air in the hose? When you used it in the tank that wouldn't suck up, did it at least suck up the water?

110g Tropical Community & Sakura Shrimp
55g BN Breeding Grounds, Peacock Gudgeons, Panda, Pygmies, & Smudge Spot Cories, Rili Shrimp
10g RCS and show guppies

MIAPG - Come join us - Plantedtank - MI - Greatlakesaquaria
GMYukonon24s is offline  
post #6 of 9 (permalink) Old 12-11-2012, 02:02 PM
Planted Tank Obsessed
Join Date: Feb 2010
Location: Woodstock, IL
Posts: 354
Does it have a squeeze bulb for starting?

I gave up on those a long time ago. There's a one way flapper valve on the end of the squeeze bulb that was always getting clogged with goo.

Now I just pinch off the hose a few feet down, fill it with water, then release the pinch. Suction/flow is much better without the bulb.
dmagerl is offline  
post #7 of 9 (permalink) Old 12-11-2012, 02:08 PM
Planted Tank Guru
mott's Avatar
Join Date: Nov 2006
Location: nj
Posts: 2,043
Make sure water is filling the tube and output is well below the tank, otherwise you might have weak suction.
mott is offline  
post #8 of 9 (permalink) Old 12-12-2012, 02:01 AM Thread Starter
Wannabe Guru
Join Date: Oct 2012
Location: hawaii
Posts: 1,106
Yes it did suck up water, no i dont have a bulb one it is the kind in the link i posted and the outlet tube is at leat 3ft below the tank
fishkeeper01 is online now  
post #9 of 9 (permalink) Old 12-12-2012, 06:47 AM
Planted Tank Enthusiast
Join Date: Jun 2012
Location: NE TN
Posts: 588
Where the gravel tube connects to the hose is there a plastic screen filter that might be clogged. I've had that happen before. Had to take the clear tube off from the blue outer part to get to it and clean it.
sowNreap is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome