Question about setting up Co2 regulator - The Planted Tank Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 40 (permalink) Old 11-10-2012, 04:48 PM Thread Starter
Algae Grower
 
Join Date: Nov 2012
Location: Raleigh NC
Posts: 17
Question about setting up Co2 regulator

Hello -

I am finally setting up a pressurized CO2 system after staring at a new empty intimidating CO2 tank for 5 years. I bought a nice regulator from Green Leaf Aquariums and it seems I misread the instructions on setting the low pressure gauge. It said to turn it to 10 and I did but afterward I realized it was not the 10 at the end of the dial, it was 10 psi on the inside dial - a much lower setting. Now I have no idea how to bring it back down. I have tried loosening the handle, shutting everything off and starting over - it is still dialed up all the way. Any advise for this dumb blonde?

Thanks!
trixylarue is offline  
Sponsored Links
Advertisement
 
post #2 of 40 (permalink) Old 11-10-2012, 05:01 PM
Moderator
 
Darkblade48's Avatar
 
Join Date: Jan 2008
Location: Toronto/Singapore
Posts: 10,297
Oh dear, you turned it to 10 bar and not 10 PSI? I'm surprised the regulator managed to actually deliver such a high output; please be careful, as the regulator's interior parts may break or the manometer (gauge) needle may become stuck.

In any case, if you back off the regulator (turning the knob counter clockwise), it will take some time for the gas that is remaining in the regulator to off gas.

To help the process along, just plug in the solenoid and open your needle valve all the way (counter clockwise turns). Ensure that the CO2 is not off gassing into your aquarium. Hopefully, the manometer needle is not stuck.

Anthony

A Primer to Pressurized CO2 and A Primer to Planted Tanks
Eheim Pimp #362 - Eheim 2213 x2, Eheim 2028, Eheim 2217, Eheim surface skimmer and Eheim autofeeder.
Victor Pimp #33 - HPT272-125-350-4M
Darkblade48 is offline  
post #3 of 40 (permalink) Old 11-10-2012, 05:01 PM
Algae Grower
 
TheKribKeeper's Avatar
 
Join Date: Oct 2012
Location: California
Posts: 130
Turn the tank valve off then turn the regulator knob counter clockwise until no resistance is felt and open the needle valve all the way open and it should vent the excess pressure. Then open the tank valve before you turn the regulator knob clockwise until you get to 10 psi not 10 bar. If you open the tank valve with the regulator turned all the way clockwise it will ruin the low pressure gauge and the needle will peg out on the gauge. I hope you did not do that in the first place otherwise you will have to replace the low pressure gauge.
TheKribKeeper is offline  
post #4 of 40 (permalink) Old 11-10-2012, 05:14 PM Thread Starter
Algae Grower
 
Join Date: Nov 2012
Location: Raleigh NC
Posts: 17
Thanks for the reply. Once I loosened it and plugged in the Solenoid it started coming back down. However, while I have plenty of bubbles going through the bubble counter, nothing is going up to the diffuser? What could I have done wrong?
trixylarue is offline  
post #5 of 40 (permalink) Old 11-10-2012, 05:14 PM
Algae Grower
 
TheKribKeeper's Avatar
 
Join Date: Oct 2012
Location: California
Posts: 130
Also check the date on your co2 tank they have to be hydrotested every 5 years so if you have had it for 5 years I would trade it in instead of refilling otherwise it will have to be recertified which cost around $30.00 in my town. The date is stamped in the top where it first starts to get fat.
TheKribKeeper is offline  
post #6 of 40 (permalink) Old 11-10-2012, 05:18 PM Thread Starter
Algae Grower
 
Join Date: Nov 2012
Location: Raleigh NC
Posts: 17
I learned that when I took it to be filled. I had to take it somewhere else to have it tested first. It's all good now, except it would be nice if I had CO2 going into the tank.
trixylarue is offline  
post #7 of 40 (permalink) Old 11-10-2012, 05:19 PM
Algae Grower
 
TheKribKeeper's Avatar
 
Join Date: Oct 2012
Location: California
Posts: 130
If it is a ceramic diffuser it will require more than 10 psi. More like 25-35psi. My up aqua inline diffuser runs at 22psi. The bubble counter will slow down to a stop once the pressure equalizes at 10psi. I kept raising it 5psi at a time until the bubble counter stabilized to find the working pressure I needed. ie raise it 5psi then wait until the bubble stops about 20-30 minutes or so and repeat until the bubble counter stops fluctuating then fine tune the needle valve.
TheKribKeeper is offline  
post #8 of 40 (permalink) Old 11-10-2012, 05:25 PM Thread Starter
Algae Grower
 
Join Date: Nov 2012
Location: Raleigh NC
Posts: 17
It is the Atomic diffuser from Green Leaf. I have the pressure at 30 right now but still nothing going to the tank.
trixylarue is offline  
post #9 of 40 (permalink) Old 11-10-2012, 05:31 PM
Algae Grower
 
TheKribKeeper's Avatar
 
Join Date: Oct 2012
Location: California
Posts: 130
I beleive the GLA diffuser needs 36psi to operate it has finer pores than th up aqua model. Try that.
TheKribKeeper is offline  
post #10 of 40 (permalink) Old 11-10-2012, 05:32 PM
Algae Grower
 
TheKribKeeper's Avatar
 
Join Date: Oct 2012
Location: California
Posts: 130
Also it might have water in it which will take a little while to push back out.
TheKribKeeper is offline  
post #11 of 40 (permalink) Old 11-10-2012, 05:36 PM Thread Starter
Algae Grower
 
Join Date: Nov 2012
Location: Raleigh NC
Posts: 17
I have it at 50 and still nothing. I will still see if it just needs time. I'm missing my DIY already LOL.
trixylarue is offline  
post #12 of 40 (permalink) Old 11-10-2012, 05:43 PM Thread Starter
Algae Grower
 
Join Date: Nov 2012
Location: Raleigh NC
Posts: 17
Just for kicks I tried a different diffuser (glass) and still nothing.
trixylarue is offline  
post #13 of 40 (permalink) Old 11-10-2012, 05:43 PM
Algae Grower
 
TheKribKeeper's Avatar
 
Join Date: Oct 2012
Location: California
Posts: 130
Is it an in tank model if so it will definately have water in it. My inline model got water in it when I started it at 10 psi. Or you can turn the co2 off take it out of the tank disconnect the co2 tubing and empty the water out then reconnect it turn the co2 back to 36psi or 50psi before you put it back in the tank that way it wont have to push out the water.
TheKribKeeper is offline  
post #14 of 40 (permalink) Old 11-10-2012, 05:44 PM
Algae Grower
 
TheKribKeeper's Avatar
 
Join Date: Oct 2012
Location: California
Posts: 130
Open your needle valve all the way then back it off to speed things up.
TheKribKeeper is offline  
post #15 of 40 (permalink) Old 11-10-2012, 05:45 PM
Algae Grower
 
TheKribKeeper's Avatar
 
Join Date: Oct 2012
Location: California
Posts: 130
But dont gas your fish.
TheKribKeeper is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome