Rena Filstar XP3 - larger o-rings? - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-15-2010, 03:48 PM Thread Starter
PTrader: (0/0%)
Join Date: Feb 2010
Location: Albuquerque, NM
Posts: 1
Rena Filstar XP3 - larger o-rings?

I got a Rena Filstar XP3 thrown in with my 75G tank that I'm setting up now. I'm planning on pretty heavily planted with some fish (not a ton, but maybe ~30 inches?). I'm using a Hydor in-line heater and a Rex reactor for CO2. The filter ran fine for about a week before I added the reactor and heater, but now it leaks out of the power cord hole after about an hour. I replaced the o-rings on the quick disconnect, and re-greased them (and the rings inside the disconnect too). It ran for about 5 hours and then started leaking. Anyone try using larger o-rings to stop the leaking? I'm ready to just bag this filter and buy another one (Eheim 2217?) but I thought I'd give the Rena one more chance!
jawn_nm is offline  
Sponsored Links
post #2 of 3 (permalink) Old 02-15-2010, 04:49 PM
Planted Tank Guru
PTrader: (0/0%)
Join Date: Jan 2010
Location: Contra Costa CA
Posts: 10,309
I have done about what you have: I used Vaseline for lubricant and a bit of bulk to make the O-rings seat better.
Rena suggests replacing the O-rings pretty frequently (3 years?)

I am not running anything in-line, though. Do you think there is too much interference with the in line stuff? Is it easy enough to dismantle it and run the filter without to test it again?
Diana is offline  
post #3 of 3 (permalink) Old 02-15-2010, 04:58 PM
Algae Grower
PTrader: (0/0%)
Join Date: Sep 2008
Location: Rochester, NY
Posts: 34
The leaky power cord is a known issue. What I did was take the top off my XP3, unscrew the two pieces that are basically "pinching" the power cord in place. Then I added some silicone along the power cord and screwed the two pieces together again. Haven't had a leak since.

themainer is offline  

leak, power, rena, ring, xp3

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome