Some fatalities with No-Planaria - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-18-2014, 02:16 PM Thread Starter
Planted Tank Enthusiast
Aplomado's Avatar
PTrader: (3/100%)
Join Date: Feb 2013
Location: USA
Posts: 882
Some fatalities with No-Planaria

I've got a colony of a few hundred cherries, and had a bad planaria infestation.

Dosed for three days at the recommended amount. Did a water change after that.

I did see at least three dead shrimp. Seeing dead shrimp is very rare in this tank. This stuff appears to not be 100% shrimp safe as claimed.

edit- I have seen one or two planaria that look sick, but not dead. They may have been hiding in the substrate. A lot less that normal though. I hope I don't need to dose again, I hate losing shrimp.

Last edited by Aplomado; 07-18-2014 at 04:33 PM. Reason: more info
Aplomado is offline  
Sponsored Links
post #2 of 2 (permalink) Old 07-19-2014, 02:31 AM
Planted Member
PTrader: (0/0%)
Join Date: Feb 2014
Location: deep
Posts: 207
Do you dose any ferts? I think I recall some posts (elsewhere) pointing to ferts + NP as being problematic.
Also, did you increase aeration?

aquatic plant newbie (but a plantaholic above the water)
10G: shrimp only
29G: fish...needs a total redo!
35ppt is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome