Sachem flourish vs snails - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 06-29-2013, 06:59 PM Thread Starter
Wannabe Guru
 
tattooedfool83's Avatar
 
Join Date: Mar 2013
Location: North Providence, RI
Posts: 1,866
Sachem flourish vs snails

Would using flourish in my tank hurt the snails? I've had a die off it seems with my mts. Not sure why
tattooedfool83 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-29-2013, 07:05 PM
Planted Tank Obsessed
 
Dan's85's Avatar
 
Join Date: Mar 2013
Location: Montrose, Co
Posts: 357
I've used it regularly in my 40b before I tore it down to rescape, and never had any problems with my mystery snail.

The Fraternity of Dirt #136
Just because its dirt doesn't make it low tech


40b tank journal
http://www.plantedtank.net/forums/sh...594&highlight=
10g NPT Betta tank
http://www.plantedtank.net/forums/sh...d.php?t=358321
Dan's85 is offline  
post #3 of 9 (permalink) Old 06-29-2013, 08:11 PM
Algae Grower
 
Join Date: Feb 2013
Location: santa paula, ca, United States
Posts: 148
Hasn't seemed to bother my snails. MTS, ramshorn, pond, and nerite. I dose heavy, the recommended initial dose on a daily basis.
ckraft is offline  
post #4 of 9 (permalink) Old 06-29-2013, 09:06 PM
Planted Tank Enthusiast
 
Join Date: Jan 2013
Location: USA
Posts: 732
I don't use it in shrimp tanks to play it safe but is has never adversely affected any of my snails.
Puddles is offline  
post #5 of 9 (permalink) Old 06-29-2013, 09:22 PM
Planted Tank Enthusiast
 
Join Date: Feb 2012
Location: CA, USA
Posts: 805
I dose Seachem Flourish once a week on 3 of my shrimp tank that has various snails in it, spixi, mts, nerite. They're safe!
CookieM is offline  
post #6 of 9 (permalink) Old 06-29-2013, 09:31 PM Thread Starter
Wannabe Guru
 
tattooedfool83's Avatar
 
Join Date: Mar 2013
Location: North Providence, RI
Posts: 1,866
Thanks for the responses. For whatever reason it seems my mts in one tank are dropping dead
tattooedfool83 is offline  
post #7 of 9 (permalink) Old 06-29-2013, 09:33 PM
Planted Tank Enthusiast
 
Join Date: Feb 2012
Location: CA, USA
Posts: 805
Could be low calcium, low ph below 7, high copper. Check your water parameters and let us know to figure it out.
CookieM is offline  
post #8 of 9 (permalink) Old 06-29-2013, 09:38 PM
Planted Tank Enthusiast
 
Join Date: Jan 2013
Location: USA
Posts: 732
And just to make sure, you are cycled and everything right? Sorry, have to ask
Puddles is offline  
post #9 of 9 (permalink) Old 06-29-2013, 10:31 PM Thread Starter
Wannabe Guru
 
tattooedfool83's Avatar
 
Join Date: Mar 2013
Location: North Providence, RI
Posts: 1,866
Ph-7.2-7.4
Ammonia-0
Nitrites-0
Nitrates-5-10ppm

Tanks definitely cycled, it's been set up for maybe 2 months but the canister filter on it has been running for 6 months with heavy bioload so no worries there. I don't have a copper test that's why I was wondering and figured I'd ask here. I'm doing nothing different them I've been doing and I change around 20% of the water weekly
tattooedfool83 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome