Optimal substrate - Page 2 - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #16 of 16 (permalink) Old 04-05-2013, 10:29 PM
Planted Tank Guru
Bananariot's Avatar
Join Date: Feb 2012
Location: Biddeford, Maine
Posts: 2,640
Originally Posted by mnemenoi View Post
+1 Neos do fine in higher Ph and thrive. Our tap is 7.8-8.2 and they breed like rabbits. About the only issue they have is temperature fluctuation, bad water parameters, predators, and low Ph water. Otherwise they'll live and breed anywhere. I have had them breeding in anything from a vase on the kitchen counter to our Fahaka puffer Eheim filter... CRS/tigers are a completely different animal and require vastly different parameters
Neos have a tendency to thrive anywhere but amazonia could push pH into the 5 range.....which is possible for neos....but for some that may come from 8 pH could be detrimental.

Plus I feel like it's a waste to use it on neo's. Just an economical view from a college kid xD
Bananariot is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome