Copper in water.. WHAT TO DO!?! - The Planted Tank Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 02-06-2013, 02:03 AM Thread Starter
Planted Tank Enthusiast
 
Kinection's Avatar
 
Join Date: Dec 2012
Location: Anaheim, CA
Posts: 931
Copper in water.. WHAT TO DO!?!

Well... long story short is that my dad was dosing ich removal liquid and accidently put his fingers into my shrimp tank while I was gone. I lost 4 CRS and starting to lose my fire reds. One died yesterday morning, it had a white stripe on it's back, probably from old age right? Wasn't worried much until I saw a dead juvenile. They all looked fine until I saw this one 1 hour after feeding. It's head has a yellow square covering the whole thing... is it bacteria infection or something? How do I remove the copper, WC? It was a little, but that might not matter... I've gotten tiny little worms in my tank too, they don't look like planaria because they don't have the triangular point. Any ideas why they are starting to die?

- Brian
That one guy that is always online.
Kinection is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 02-06-2013, 02:06 AM
Planted Tank Guru
 
GeToChKn's Avatar
 
Join Date: Apr 2011
Location: Hamilton, Ontario, Canada
Posts: 5,116
What ich med. It might not even have copper. I don't know if a dip from a finger with a bit on it would be enough.

The worms are probably from over feeding and not enough water changes and your water quality is bad. Worms only develop like that from either really bad water quality or transferred from something else, but if don't over feed, worms don't usually come or live.

If you water is bad, that could explain the deaths.

20g platy, , 2 x 10g shrimp, 3 x 20g shrimp, 7.5g shrimp and 1 great dane/mastiff puppy.

Sump Pimp #2

My Tanks and my shrimps
GeToChKn is offline  
post #3 of 17 (permalink) Old 02-06-2013, 02:09 AM Thread Starter
Planted Tank Enthusiast
 
Kinection's Avatar
 
Join Date: Dec 2012
Location: Anaheim, CA
Posts: 931
Well that probably isn't the reason why... BUT. Maybe they started coming in with the dwarf water lettuce I bought. I'll test my water again, just did a WC on Saturday though.

- Brian
That one guy that is always online.
Kinection is offline  
post #4 of 17 (permalink) Old 02-06-2013, 02:09 AM
Planted Tank Enthusiast
 
azjenny's Avatar
 
Join Date: Dec 2011
Location: Paradise Valley, AZ
Posts: 650
Copper in water.. WHAT TO DO!?!

The yellow square on the head sounds like a saddle, which, if it is, just means that it's a female. Those are the eggs inside her body.
Not a problem if so. Do you have any pics?
azjenny is offline  
post #5 of 17 (permalink) Old 02-06-2013, 02:10 AM
Planted Tank Guru
 
GeToChKn's Avatar
 
Join Date: Apr 2011
Location: Hamilton, Ontario, Canada
Posts: 5,116
What ich med was is?

20g platy, , 2 x 10g shrimp, 3 x 20g shrimp, 7.5g shrimp and 1 great dane/mastiff puppy.

Sump Pimp #2

My Tanks and my shrimps
GeToChKn is offline  
post #6 of 17 (permalink) Old 02-06-2013, 02:14 AM Thread Starter
Planted Tank Enthusiast
 
Kinection's Avatar
 
Join Date: Dec 2012
Location: Anaheim, CA
Posts: 931
http://www.drsfostersmith.com/produc...m?pcatid=21422
Herbtana Ich removal. Petco dude told me it has copper... might have not listened to him...

- Brian
That one guy that is always online.
Kinection is offline  
post #7 of 17 (permalink) Old 02-06-2013, 02:16 AM
Planted Tank Enthusiast
 
Join Date: Jan 2013
Location: USA
Posts: 732
It's description says it is an herbal supplement to boost fish immune systems. I doubt it has copper in it. I agree that if you have worms, a likely culprit for the death of your shrimp is poor water quality. A large water change or multiple small water changes may help the situation.
Puddles is offline  
post #8 of 17 (permalink) Old 02-06-2013, 02:19 AM Thread Starter
Planted Tank Enthusiast
 
Kinection's Avatar
 
Join Date: Dec 2012
Location: Anaheim, CA
Posts: 931
I just tested my water, Nitrates 0, Nitrite 0, and Ammonia 0. My pH is still 7.4
I really don't think it's my water quality, but if it's what you guys suggest, I'll do a WC right now.

- Brian
That one guy that is always online.
Kinection is offline  
post #9 of 17 (permalink) Old 02-06-2013, 02:22 AM
Planted Tank Enthusiast
 
aznrice247's Avatar
 
Join Date: Feb 2012
Location: NY
Posts: 679
7.4 is a bit too high for CRS
aznrice247 is offline  
post #10 of 17 (permalink) Old 02-06-2013, 02:23 AM Thread Starter
Planted Tank Enthusiast
 
Kinection's Avatar
 
Join Date: Dec 2012
Location: Anaheim, CA
Posts: 931
Quote:
Originally Posted by aznrice247 View Post
7.4 is a bit too high for CRS
Yea, my FSS stopped buffering. I should of gotten ADA in the first place. *FACEPALM*

- Brian
That one guy that is always online.
Kinection is offline  
post #11 of 17 (permalink) Old 02-06-2013, 02:25 AM
Planted Tank Guru
 
GeToChKn's Avatar
 
Join Date: Apr 2011
Location: Hamilton, Ontario, Canada
Posts: 5,116
Everything about that products screams natural herbal treatment.

The 7.4 isn't good for the crystals, especially if the gH/kH aren't in line.

Are you sure you did nitrate test right, unless your tank is planted very well. I don't overfeed, have floaters, moss, WC and still have small nitrates.

To me, the random small white worms on the glass have always been to me overfeeding and not changing my water enough. I was sick last week, feed too much not keeping track properly, skipped my water change, I have worms on my glass now. I know what the reason is. Cut back on my feeding, suck them off the glass with a syringe, do some water changes, should be gone in a bit.

20g platy, , 2 x 10g shrimp, 3 x 20g shrimp, 7.5g shrimp and 1 great dane/mastiff puppy.

Sump Pimp #2

My Tanks and my shrimps
GeToChKn is offline  
post #12 of 17 (permalink) Old 02-06-2013, 02:31 AM Thread Starter
Planted Tank Enthusiast
 
Kinection's Avatar
 
Join Date: Dec 2012
Location: Anaheim, CA
Posts: 931
Just finished doing my water change. The waiting game... begins. Thanks for the help guys.

- Brian
That one guy that is always online.
Kinection is offline  
post #13 of 17 (permalink) Old 02-06-2013, 02:32 AM
Planted Tank Guru
 
GeToChKn's Avatar
 
Join Date: Apr 2011
Location: Hamilton, Ontario, Canada
Posts: 5,116
How long did you have your fluval stratum and how much water did you change?

20g platy, , 2 x 10g shrimp, 3 x 20g shrimp, 7.5g shrimp and 1 great dane/mastiff puppy.

Sump Pimp #2

My Tanks and my shrimps
GeToChKn is offline  
post #14 of 17 (permalink) Old 02-06-2013, 02:34 AM Thread Starter
Planted Tank Enthusiast
 
Kinection's Avatar
 
Join Date: Dec 2012
Location: Anaheim, CA
Posts: 931
10% WC and I had the stratum for about 4-6months. I use ordinary tap with Seachem Prime.

- Brian
That one guy that is always online.
Kinection is offline  
post #15 of 17 (permalink) Old 02-06-2013, 03:20 AM
Planted Tank Guru
 
wicca27's Avatar
 
Join Date: May 2009
Location: Dewey
Posts: 4,850
Send a message via Yahoo to wicca27
i must have really lucked out with my fss ive had it for a year now and it takes my tap water from a ph of 7.4 down to 6 and it still buffers
wicca27 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome