strange 1 cherry and 1 crs died - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-30-2013, 11:43 PM Thread Starter
Planted Tank Obsessed
Join Date: Mar 2008
Location: ARDMORE PA
Posts: 460
strange 1 cherry and 1 crs died

well i had 1 cherry freaking out fell on back i scooped him up took him out to see if molting issue his molt came off and he was fine.

yesterday i found a cherry shrimp on his back just dead every other tank mate is fine. till just now i found a teenager sized crs on his back.

ph is 6.2-6.4
kh is high 2 low 3 range
gh is 7ish

ive bin doing 6 gallons ro to 1 gallon treated tap water changed out about a total of 25-30 gallons of my 40 b over the last week at 2 day intervals.

and used flourish and and iron an k suplement

other than that the only thing i did was rinse filter pads in spring water and took out 1/4 of the bio rings to get more flow. filter is a rena rated for 45 gallons. also have a powerhead with floss for a prefilter/filter

could i have removed too much bacteria at once or what idk

also i trimmed my whole tank and found about 18 crs as i only thought i had 6 then 9 with the whole tetra incediant so im quite happy bout that but this yesterday and today idk what to make of it.
pirayaman is offline  
Sponsored Links
post #2 of 5 (permalink) Old 01-31-2013, 12:11 AM
Planted Tank Guru
msjinkzd's Avatar
Join Date: May 2007
Location: mount wolf, pa
Posts: 3,870
Send a message via AIM to msjinkzd
have you tested your tank for ammonia and nitrite?
msjinkzd is online now  
post #3 of 5 (permalink) Old 01-31-2013, 01:45 AM Thread Starter
Planted Tank Obsessed
Join Date: Mar 2008
Location: ARDMORE PA
Posts: 460
no and whats strange is i never removed the crs and was clearly on his back not moving. and now its gone cant find a dead crs anywhere so strange i swear idk what is going on.
can they get fake death or something. i removed the cherry yesterday and threw her out maybe i should have left to see.
ive seen some of them do this freak wiggle thing fall on there back but they always get back up idk whats going on. could this be a molting issue? idk but i always find a ton of molt shells.
pirayaman is offline  
post #4 of 5 (permalink) Old 01-31-2013, 01:50 AM
Planted Tank Enthusiast
rodcuda's Avatar
Join Date: Jul 2012
Location: Central Florida
Posts: 843
Are you feeding them a lot of protein? It sounds like a molting issue.

rodcuda is offline  
post #5 of 5 (permalink) Old 01-31-2013, 01:54 AM Thread Starter
Planted Tank Obsessed
Join Date: Mar 2008
Location: ARDMORE PA
Posts: 460
i dont feed them. i put fish flakes every 3 days cause my amanos like them i guess the crs and cherrys get some idk
pirayaman is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome