What's up with these plants? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-04-2014, 10:51 PM Thread Starter
Algae Grower
 
Join Date: Dec 2012
Location: Toronto
Posts: 46
What's up with these plants?

Hello Everyone,

I got these plants and they seem to be getting holes in their leaves as you will see in the pics below. I was wondering if they are caused by fish or deficiency. I have tetras,plecos,rainbows and some barbs.I recently started dosing with excel, flourish, and iron once a week. My tank is 90g, 24" tall and my light fixture is:Current USA Satellite 48-60". The Ozelot sword has been in the tank for about 2+ months, where as the other plant I got about 10 days ago

Here are the pics:
Click image for larger version

Name:	IMG_9946.jpg
Views:	48
Size:	48.9 KB
ID:	284010

Click image for larger version

Name:	IMG_9945.jpg
Views:	48
Size:	65.5 KB
ID:	284018

Click image for larger version

Name:	IMG_9944.jpg
Views:	49
Size:	43.2 KB
ID:	284026

Thanks

Last edited by mitko1994; 03-06-2014 at 09:00 PM. Reason: typo
mitko1994 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-04-2014, 11:01 PM
Planted Tank Enthusiast
 
foster's Avatar
 
Join Date: Sep 2012
Location: Gladwin Michigan
Posts: 862
It possibly is a potassium deficiency. I use leafzone when I have plants that look like those. It usually clears up in a few weeks. The old leaves won't repair, but new leaves will be better. One more thing, do you have pond snails in your tank?
foster is offline  
post #3 of 7 (permalink) Old 03-05-2014, 04:56 PM Thread Starter
Algae Grower
 
Join Date: Dec 2012
Location: Toronto
Posts: 46
As fair as I know I have no snails but even if I did I have clown loaches, so they would have eaten them all. Are deficiencies quickly noticed, I mean would they appear in the first 2-3 days because that's when these holes appeared? Would you recommend leafzone over Seachem plant products?
mitko1994 is offline  
post #4 of 7 (permalink) Old 03-05-2014, 09:52 PM
Planted Member
 
Join Date: Nov 2013
Location: New York City
Posts: 194
Is this happening to old leaves, new leaves, or all leaves?
TyrannosaurusSex is offline  
post #5 of 7 (permalink) Old 03-06-2014, 04:51 PM Thread Starter
Algae Grower
 
Join Date: Dec 2012
Location: Toronto
Posts: 46
I would say the old leaves, since the plants haven't produced any new leaves
mitko1994 is offline  
post #6 of 7 (permalink) Old 03-06-2014, 05:40 PM
Planted Tank Guru
 
Raymond S.'s Avatar
 
Join Date: Dec 2012
Location: Hot Springs Ar. 71901
Posts: 5,825
In the third picture, it's Pleco damage. Random holes are usually Potassium butalong the middle of the leaf is from a Pleco. Sometimes giving them a good supply of other food stops that. Other times it don't and then you have a choice to make.
Either will do especially if you already have one kind. Either of them is expensive compared to dry ferts.
If you haven't had any growth in 10 weeks then you are missing something like ferts and/or enough light. Fish food and fish waste provides enough nutrients for a few plants but to get growth out of anything like several plants that won't be enough.
I'll give you a link that gives an easy to understand explanation of this.
DIY CO2 for the Newbie setup
An alternative would be root tabs. The ones in stores aren't much good as they are incomplete. There is one sold on here that is but it's tricky to use and must not be over done. But read the link and then get back/w the next question...LOL...

The shortest distance between any two points is a straight line...in the opposite direction...
Raymond S. is online now  
post #7 of 7 (permalink) Old 03-06-2014, 09:00 PM Thread Starter
Algae Grower
 
Join Date: Dec 2012
Location: Toronto
Posts: 46
Thanks Raymond, There was a typo in my original post, I meant to say 10 days instead of 10 weeks, LOL but the Ozelot sword has been in my tank for 2+ months. What dry ferts would you suggest or is that a fancy way of saying bags of soil? I feed them pleco waffers everyday plus whatever else they find on the bottom.

Thanks
mitko1994 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome