Hagen Customer service experiences? My Ebi issue - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-08-2014, 06:41 PM Thread Starter
Planted Member
DTDPlanted's Avatar
Join Date: Apr 2012
Location: Port Saint Lucie, FL
Posts: 299

So my Ebi arrived yesterday and from the long history of background adhesion stories and a visual inspection from myself I thought it best to play it safe and re-attach the background more firmly myself. I went about searching on the best way to do it when I came across a forum thread from a few years back stating when people had this issue Hagen was sending some aquarium sealant so they could re-apply the background. Everyone was claiming a no questions asked and extremely helpful attitude from the CSRs. When I called called Hagen today I got the "send it back to amazon for a replacement or DIY" response. No offer to send me some sealant even when I asked if they could just send some....I have had pleasant dealings with Hagen in the past but this is starting to leave a bad taste in my mouth. I just dont think I should have to pay $7-12 to fix a problem with the tank that Hagen has known about for years. Does anyone have any current experiences with warranty replacement, Ebi specific would help. I will be submitting an email and complaining about the issue as well for good measure, maybe I can make something happen


That is the forum post where they discuss getting the silicon from Hagen

Bump, I sent an email. We will see what they come up with. I filled the tank with tap water to see what would happen and confirmed that about 5 of the 10 dots were actually holding the background, the others are all just stuck to the tank

Last edited by Darkblade48; 01-09-2014 at 03:20 AM. Reason: Back to back posts
DTDPlanted is offline  
Sponsored Links
post #2 of 2 (permalink) Old 01-08-2014, 11:24 PM
Planted Tank Enthusiast
Join Date: Sep 2007
Location: Alexandria, VA
Posts: 588
I haven't dealt with them RE the background, but the early models had lights that would often burn out after 1-3 months, and they replaced my light fixture. I think I just emailed them a picture of the receipt.
jrh is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome