Black floaty stuff in new bottle of prime? - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-20-2013, 07:13 PM Thread Starter
Planted Tank Obsessed
Join Date: Jul 2013
Location: Maine
Posts: 417
Black floaty stuff in new bottle of prime?


Just opened up a new bottle of prime and inside the bottle I see what looks like little flecks of black (like particles of carbon). The bottle also doesn't really smell like sulfer like my last one.

Is this weird?
Positron is offline  
Sponsored Links
post #2 of 4 (permalink) Old 10-20-2013, 07:17 PM
Planted Tank VIP
chad320's Avatar
Join Date: Mar 2010
Location: Spring Valley, IL
Posts: 7,700
Yes, its weird. I would look the bottle over for an expiration date.
chad320 is offline  
post #3 of 4 (permalink) Old 10-20-2013, 07:57 PM
Planted Tank Enthusiast
Join Date: Apr 2012
Location: Edmonton, Canada
Posts: 789
The black floaties are normal for a bottle of prime. As for the smell... Prime has it's own characteristic smell.
creekbottom is offline  
post #4 of 4 (permalink) Old 10-20-2013, 08:16 PM
Planted Tank Obsessed
tithra's Avatar
Join Date: Dec 2012
Location: Vermont
Posts: 439
Seachem states that the black flecks are normal. I have had some bottles that have them and some that don't.
tithra is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome