Wanted: Crypt Balansae or Retrospiralis - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-11-2014, 02:55 AM Thread Starter
Planted Member
skelley's Avatar
Join Date: Jul 2011
Location: Troutdale, OR
Posts: 162
Wanted: Crypt Balansae or Retrospiralis

Wondering if anyone in OR has any Crypt Balansae or Retrospiralis. Close to Portland is great or even if it is out of town and you would to pop in it a bubble mailer... It would probably arrive in better condition than my usual go to folks at APC considering the awful weather most of the country has right now.
skelley is offline  
Sponsored Links
post #2 of 2 (permalink) Old 01-16-2014, 08:06 AM
Wannabe Guru
Higher Thinking's Avatar
Join Date: Mar 2011
Location: Oregon State Beavers!
Posts: 1,531
I have a bunch of spiralis/retrospiralis. I can't guarantee which one because as you may know, the plants are nearly identical except for the flower. Send me a pm if you're still interested. Thanks.
Higher Thinking is online now  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome