I'm so disillusioned - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-19-2014, 10:32 PM Thread Starter
Planted Tank Enthusiast
Join Date: Jul 2011
Location: kew gardens ny
Posts: 884
I'm so disillusioned

Hey everyone
Okay I've been in the hobby for years and back in the day I was clueless. I would over stock change the water once a month and never test. From what I remember I had very few problems. Fast forward I have a 75 gallon tank with a fluvial 405 a fluvial 206 a aquclear hob 110. I do 25 gallon water changes every week. I clean my filters regularly as well as test every week. I haven't added any new fish in over 6 months and everyone was doing fine until 2 weeks ago one of my angel died for no apparent reason. I figured since the water was testing fine it was just fluke. Yesterday I noticed a couple of white spots (not like ick more protruding) and her poop is white. I started tetra parasite guard today. I just didn't understand. I feel like what more can I do?
I just want to hang my head down
partobe is offline  
Sponsored Links
post #2 of 5 (permalink) Old 08-19-2014, 10:52 PM
Planted Tank Obsessed
DayOlder's Avatar
Join Date: Jul 2014
Location: Aurora Colorado
Posts: 454
I think the problem is that everything was going so good for so long you thought you had it under control when in fact, and you have to know this if you've been in it this long, we are never really in control. The best we can hope for is a rest period between battles. I'm sorry but I'm clueless about your Angles and I would of started some sort of parasite treatment like you did but I do know you and your tank will get through it. Hope someone has a better idea of what is going on with your tank.
DayOlder is offline  
post #3 of 5 (permalink) Old 08-19-2014, 11:33 PM Thread Starter
Planted Tank Enthusiast
Join Date: Jul 2011
Location: kew gardens ny
Posts: 884
Thanks day older :-)
partobe is offline  
post #4 of 5 (permalink) Old 08-20-2014, 12:47 AM
Planted Member
Join Date: Sep 2012
Location: nyc
Posts: 181
you gotta deworm them from time to time.
20cc is offline  
post #5 of 5 (permalink) Old 08-20-2014, 01:44 AM Thread Starter
Planted Tank Enthusiast
Join Date: Jul 2011
Location: kew gardens ny
Posts: 884
Thanks 20cc
I dosed the tank with tetra parasite guard hopefully it will work and there will be no white poop tomorrow
partobe is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome