LF: Used Fliter Media or gravel - Page 2 - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #16 of 17 (permalink) Old 02-07-2014, 08:07 PM Thread Starter
Algae Grower
Join Date: Jan 2014
Location: Elk Grove, CA
Posts: 12
Originally Posted by dubels View Post
Looks like I will have some filter media for you after all. Was home helping my parents clean their XP2 filter when I dropped it and shattered the corner of the canister. What kind of filter do you have? I have some Rena bio stars that are ready to go. Problem is that I wont be back in Sac until Sunday and not sure if they will fit in your filter. Will let you know how much I will have tomorrow once I get a replacement going.
Hello! Didn't see this until now. I added TSS and I think the tank will be cycled soon so not sure that I need to get any media at this point. Parameters are:

Ammonia: 0
Nitrite: 3-4
Nitrate: 20-30
Kellye8498 is offline  
Sponsored Links
post #17 of 17 (permalink) Old 02-07-2014, 08:22 PM Thread Starter
Algae Grower
Join Date: Jan 2014
Location: Elk Grove, CA
Posts: 12
What is the size of the bio stars? I can see if they will fit. It's an Aqueon QuietFlow
Kellye8498 is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome