Help pond/aqarium pump needed - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-10-2012, 03:51 AM Thread Starter
Algae Grower
 
Join Date: Dec 2011
Location: Anchorage, AK
Posts: 15
Help pond/aqarium pump needed

So the pump in my 160 gallon turtle pond went tits up last night, water quality went bad fast, i lost most of my large goldfish, koi, plecos, and assorted other fish. Anyonehavea old pond pump 500gph or higher? And as a heads up dont buy lowes pond pumps, less than 6 months on it.

Sheb
Pgaks3 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-16-2012, 06:27 AM
Algae Grower
 
Join Date: Nov 2012
Location: Alaska
Posts: 56
Check out the Laguna max flow pumps, they make great pond pumps as they can handle decent sized solids. If you are not pumping up hill at all go with the max flow 600, if you have a 3-4 foot head height, get the 900. You'll have to find them online, but they really are great pumps. Pretty energy efficient too.
AKnickolai is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome