Is my Egeria densa dying? - The Planted Tank Forum

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 09-12-2013, 04:00 PM Thread Starter
Algae Grower
 
ConcaveLiNkiN's Avatar
 
Join Date: Jun 2013
Location: Singapore
Posts: 11
Dear seniors and experts,

Are you able to tell if my densas are dying?

Click image for larger version

Name:	ImageUploadedByTapatalk1379001571.739228.jpg
Views:	102
Size:	78.2 KB
ID:	207305
Click image for larger version

Name:	ImageUploadedByTapatalk1379001590.116403.jpg
Views:	88
Size:	105.9 KB
ID:	207313
Click image for larger version

Name:	ImageUploadedByTapatalk1379001606.538928.jpg
Views:	91
Size:	98.0 KB
ID:	207321
Click image for larger version

Name:	ImageUploadedByTapatalk1379001621.542767.jpg
Views:	90
Size:	93.2 KB
ID:	207329

Thank you so much in advance.


Cheers
eRic

Sent from my iPad using Tapatalk

It seems like the leaves are turning transparent. But the stems look really green. Is that normal?


Cheers
eRic

Sent from my iPad using Tapatalk

Last edited by Darkblade48; 09-27-2013 at 09:51 AM. Reason: Please use the edit function for back to back posts to keep threads cleaner
ConcaveLiNkiN is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-12-2013, 04:57 PM
Planted Tank Enthusiast
 
micheljq's Avatar
 
Join Date: Oct 2012
Location: Quebec
Posts: 815
Looks healthy to me. Leaves can be somewhat transparent on Egeria densa.

Michel.

Plants and algae grower.
micheljq is offline  
post #3 of 8 (permalink) Old 09-12-2013, 06:32 PM
Planted Tank Obsessed
 
Join Date: Jan 2012
Location: Israel
Posts: 378
Many reasons such as :Newly planted, Used excel in tank, medicated the tank,changed yr ferts, changed ferts dosage, a changed in tap water or used RO, bright light/changed yr lights, etc.. Egeria Densa is sensitive to changeds in an aquarium and it reacts by melting.
Rony11 is offline  
post #4 of 8 (permalink) Old 09-13-2013, 01:15 AM Thread Starter
Algae Grower
 
ConcaveLiNkiN's Avatar
 
Join Date: Jun 2013
Location: Singapore
Posts: 11
Quote:
Originally Posted by Rony11 View Post
Many reasons such as :Newly planted, Used excel in tank, medicated the tank,changed yr ferts, changed ferts dosage, a changed in tap water or used RO, bright light/changed yr lights, etc.. Egeria Densa is sensitive to changeds in an aquarium and it reacts by melting.
I see. Mine's a newly planted tank:
Lights: 2sets of 2x24W
Liquid fert: ADA Brighty K
Substrate: ADA Amazonia
CO2: 2bps
Lights duration: 8hrs in the evening and 3hrs morning

The stem looks really healthy and green though and I could see new shoots coming out from the stem. Therefore, I presume that the slight melting on the leaves are normal, showing a sight to actually get use to the environment?

Thanks everyone for the feedback.


Cheers
eRic

Sent from my iPad using Tapatalk
ConcaveLiNkiN is offline  
post #5 of 8 (permalink) Old 09-13-2013, 10:37 PM
Planted Tank Obsessed
 
Join Date: Jan 2013
Location: Calgary, Canada
Posts: 329
The plants leaves are only 2 cells thick
shambhalove. is offline  
post #6 of 8 (permalink) Old 09-13-2013, 10:40 PM
Planted Tank Obsessed
 
JMN16150's Avatar
 
Join Date: Jul 2012
Location: Lathrop, CA
Posts: 451
Eugeria densa also doesn't really like warm water unlike tropical plants
JMN16150 is offline  
post #7 of 8 (permalink) Old 09-14-2013, 06:07 AM Thread Starter
Algae Grower
 
ConcaveLiNkiN's Avatar
 
Join Date: Jun 2013
Location: Singapore
Posts: 11
Quote:
Originally Posted by shambhalove. View Post
The plants leaves are only 2 cells thick
2 cells thick? I tried googling on the plant, not very helpful though. Never really mention the problems people come into when caring for them. So I suppose this could be normal?


Cheers
eRic

Sent from my iPad using Tapatalk

Quote:
Originally Posted by JMN16150 View Post
Eugeria densa also doesn't really like warm water unlike tropical plants
Ah... Warm water. The temp of my water is normally 29C to 27C. I am using quadfans and do not have a chiller.


Cheers
eRic

Sent from my iPad using Tapatalk

Last edited by Darkblade48; 09-27-2013 at 09:52 AM. Reason: Please use the edit function for back to back posts to keep threads cleaner
ConcaveLiNkiN is offline  
post #8 of 8 (permalink) Old 09-27-2013, 08:32 AM Thread Starter
Algae Grower
 
ConcaveLiNkiN's Avatar
 
Join Date: Jun 2013
Location: Singapore
Posts: 11
An update on my Egeria densa. After weeks, it seems to be growing pretty okay with no signs of dying. Yesterday I did a quick relocation, I moved all my densa to a spot under my driftwood:


after a couple of minutes, guess what happened:

Yes! It started to pearl! Nice, I believe the new location provided my densa with sufficient lighting, thus causing more photosynthesis and in turn it started to pearl.
ConcaveLiNkiN is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome