flame sword, non-flowering stalk - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-14-2013, 05:03 AM Thread Starter
Algae Grower
Join Date: Aug 2012
Location: Missouri
Posts: 103
flame sword, non-flowering stalk

When I received this flame sword it had been grown emersed and had a flower stalk on it. The stalk basically consisted of a series of flower buds and leaflets...

Its grown the last six months submersed and its recently sent another stalk. But, there are no flowers... no leaflets... the nodes just have shriveled up vegetation.

The room its in is fairly dark, does the stalk itself need light to produce flowers?

One other possibility is maybe the heat from the canopy hurt it as it came out of the water? I'm not sure how long it was out before I saw it... maybe a day or two. I pulled the stalk out from under the canopy when I saw it and it has lengthened since then, but no flowers.

I'd really like to get some more actual flowers. Anybody have any ideas?

starquestMM is offline  
Sponsored Links
post #2 of 4 (permalink) Old 05-14-2013, 06:04 AM
Wannabe Guru
steven p's Avatar
Join Date: Jun 2012
Location: columbus, ne
Posts: 1,528
Swords only flower up for a day or two usually. At least, each stalk will only flower for a short time. The plant may throw off runners for a while. In my experience, the air in my house tends to be too dry if they creep out of the tank, they get funky and shrivel.
steven p is offline  
post #3 of 4 (permalink) Old 05-14-2013, 06:09 PM Thread Starter
Algae Grower
Join Date: Aug 2012
Location: Missouri
Posts: 103
Ah, I hadn't even considered that. The relative humidity in my house is around the upper 40%-lower50% right now. If thats the problem, maybe this summer when the RH is higher the stalks will be able to flower then.
starquestMM is offline  
post #4 of 4 (permalink) Old 05-25-2013, 12:46 AM Thread Starter
Algae Grower
Join Date: Aug 2012
Location: Missouri
Posts: 103
I guess I was just too antsy... the nodes are budding out and will hopefully start to open soon
starquestMM is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome