Help With My Plants - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-03-2013, 05:13 PM Thread Starter
Newbie
 
Join Date: Mar 2013
Location: United Kingdom
Posts: 2
Help With My Plants

Hi i am new to the forum i signed up today and need some advice on my plants i i have amazon sword plants and they are starting to get holes in them and brown spots all over. i have had them in the tank for about 4 weeks now i am using twin t5 28 watt daylight bulbs in my rio 125 and have the light on between 6 to 8 hours a day and i use JBl ferrpol for fert which i add weekly


fatelerror89 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-03-2013, 05:27 PM
Algae Grower
 
Join Date: Feb 2013
Location: Maryland
Posts: 25
It might be an iron deficiency
Parlorre is offline  
post #3 of 3 (permalink) Old 03-03-2013, 07:11 PM Thread Starter
Newbie
 
Join Date: Mar 2013
Location: United Kingdom
Posts: 2
i got told that because i had active carbon in my filter system it could be taking out the important stuff for the plants. so this could be why there lacking in iron ?. i have removed the carbon now
fatelerror89 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome