Xmass moss turining brown and thinning out - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 02-10-2013, 07:31 PM Thread Starter
Planted Tank Enthusiast
 
The Big Buddha's Avatar
 
Join Date: Jul 2012
Location: Montreal
Posts: 919
Xmass moss turining brown and thinning out

I have a 10G planted RCS tank with about 40-50 RCS and 4 Otto's.
The tank is about 8-9 months old.
Filtration is a Marineland C-160 and a dual sponge filter.
2 9W CFL's, no CO2, 8hrs of light a day, (4on,2off,4on)
I have minimal algae, enough to keep the Otto's busy.
The tank is mostly Java ferns which are doing great and xmas moss.
The xmas moss was thriving, full and green, and then all of a sudden starting browning at the bottom and thinning out.
I dose 0.5ml of Flourish Comp twice a week.
I do a weekly water change of 20-30% with 100% RO water + RO right. I do top offs with staight RO water.
All the other plants are doing great.

I was not trimmimg the moss, should I be keeping it short and trimmimg the moss?

Any help or suggestions would be greatly appreciated.

Thanks
The Big Buddha is online now  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-10-2013, 07:52 PM
Planted Tank Guru
 
acitydweller's Avatar
 
Join Date: Dec 2011
Location: New York
Posts: 7,695
Mosses don't turn brown unless in high temps, shading for long durations, stagnant water, or lack of nutrients... Otherwise it's pretty non fussy. How long are the moss reaching as I notice when my bunches get overgrown, the portions underneath tend to brown a bit, maybe dur to crushing or lack of light and water current...

"I am Groot", the faithful protector
acitydweller is offline  
post #3 of 6 (permalink) Old 02-10-2013, 08:00 PM
Wannabe Guru
 
steven p's Avatar
 
Join Date: Jun 2012
Location: columbus, ne
Posts: 1,528
I know ferrous sulfate is used to kill terrestrial moss... How much iron are you dosing?
steven p is offline  
 
post #4 of 6 (permalink) Old 02-10-2013, 08:01 PM Thread Starter
Planted Tank Enthusiast
 
The Big Buddha's Avatar
 
Join Date: Jul 2012
Location: Montreal
Posts: 919
Temps haven't changed since the setup, so I can rule that out- they were doing great.
There is a fair amount of current, which also has not changed.
The Moss is receiving the same amount of light, it is along the front of the tank.
I suspect maybe nutrients, but the other plants are thriving.... ?
The moss was about 3 inches total length.
The Big Buddha is online now  
post #5 of 6 (permalink) Old 02-10-2013, 08:02 PM Thread Starter
Planted Tank Enthusiast
 
The Big Buddha's Avatar
 
Join Date: Jul 2012
Location: Montreal
Posts: 919
Quote:
Originally Posted by steven p View Post
I know ferrous sulfate is used to kill terrestrial moss... How much iron are you dosing?
0.5 ml of Flourish Comp 2X a week. Nothing else.
The Big Buddha is online now  
post #6 of 6 (permalink) Old 02-10-2013, 08:07 PM
Wannabe Guru
 
Join Date: Aug 2011
Location: Centennial,Co
Posts: 1,836
My experiece with moss is that when it gets too thick it starts dieing off on the bottom. I usually diacard the lower portions and thin out the rest.
BruceF is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome