deficiency or overfertilization? - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-30-2013, 12:18 PM Thread Starter
Wannabe Guru
aokashi's Avatar
PTrader: (14/100%)
Join Date: Jun 2012
Location: New York, New York
Posts: 1,508
deficiency or overfertilization?

Hi guys, need some expertise. the plants in the picture have yellowed leaves, and the microsword seems to have light/blotchy areas.
I've been doing my HC and microswords emmersed for about 1.5 months, fertilized with osmocote plus.

Thanks in advance for your input.
aokashi is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome