Peacock moss help - The Planted Tank Forum
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-05-2012, 09:18 PM Thread Starter
Algae Grower
hotrodprincess's Avatar
Join Date: Oct 2012
Location: United States
Posts: 116
Peacock moss help

Ok we were gifted some peacock moss to make a tree out of. We kept it in a cup on the table for almost 2 weeks to be sure there were no snails in it and what not before putting it in the tank. Thursday I tied the moss to the tree and put it in the tank. This morning I noticed some of the fronds are turning brown what do I do. The tank has a18in T8 15w aqueon 8,000k Aquarium lamp in it I have been having it on from about 9 am to about 4 pm. No CO2 and NO Ferts. what could be the problem is it just adjusting to the tank Im not sure what to do. I dont want to louse it. its very beautiful.
hotrodprincess is offline  

Quick Reply

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome